CVE-2005-3787
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
CVE-2005-3787- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
CVE-2005-3787- Updated
- 2026-11-02
EUVDEUVD-2005-3782 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
EUVD-2005-3782- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-28qp-wgp5-fp7m No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
GHSA-28qp-wgp5-fp7m- Updated
- 2026-11-02
OSV No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
CVE-2005-3787- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-3787 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4-pl4 allow remote attackers to inject arbitrary web script or HTML via (1) the cookie-based login panel, (2) the title parameter and (3) the table creation dialog.
- Record
DEBIAN-CVE-2005-3787- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadminDebian:12 |
before 4:2.6.4-pl4-1 | 4:2.6.4-pl4-1 |
phpmyadminDebian:13 |
before 4:2.6.4-pl4-1 | 4:2.6.4-pl4-1 |
phpmyadminDebian:14 |
before 4:2.6.4-pl4-1 | 4:2.6.4-pl4-1 |
phpmyadminDebian:3.0 |
All versions, plus listed versions 2.2.3-13:2.6.1-pl2-13:2.6.1-pl3-13:2.6.1-pl3-23:2.6.2-rc1-1 Show 45 moreShow less4:2.10.0.2-14:2.10.1-14:2.10.1-24:2.10.1-34:2.10.2-14:2.10.3-14:2.11.0-14:2.11.1-14:2.11.1.2-14:2.11.2-14:2.11.2-24:2.11.2.1-14:2.11.2.2-14:2.11.3-14:2.11.3-24:2.11.4-14:2.11.5-14:2.11.5.1-14:2.11.5.2-14:2.11.6-14:2.11.7-14:2.11.7.1-14:2.11.7~rc2-14:2.11.8.1-14:2.11.8.1-24:2.11.8.1-34:2.11.8.1-44:2.11.8.1-54:2.11.8.1-5+lenny14:2.11.8.1-5+lenny34:2.11.8.1-5+lenny44:2.11.8.1-5+lenny54:2.11.8.1-5+lenny64:2.11.8.1-5+lenny74:2.11.8.1-5+lenny84:2.11.8.1-5+lenny94:2.11.8~rc1-14:2.6.2-14:2.6.2-24:2.6.2-34:2.6.2-3sarge14:2.6.2-3sarge24:2.6.2-3sarge34:2.6.2-3sarge44:2.6.2-3sarge5 |
None known |
phpmyadminDebian:3.1 |
before 4:2.6.2-3sarge1, plus listed versions 4:2.6.2-3 |
4:2.6.2-3sarge1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-3787 is a medium vulnerability (CVSS 4.3) in Phpmyadmin, published November 2, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in phpmyadmin 4:2.6.4-pl4-1.
References
securityfocus.com/archive/1/423142/100/0/threaded
securityfocus.com/bid/16389
phpmyadmin.net/home_page/security.php?issue=PMASA-2005-7
secunia.com/advisories/17578
secunia.com/advisories/18618
nvd.nist.gov/vuln/detail/CVE-2005-3787
github.com/advisories/GHSA-28qp-wgp5-fp7m
security-tracker.debian.org/tracker/CVE-2005-3787
Left out here: 231 versions. The JSON record has them.