Every CVE Search/ Get API key

CVE-2006-2832

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x...

2.6 LowFix available

CVE-2006-2832 is a low vulnerability (CVSS 2.6) in Drupal, published June 6, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in drupal 4.5.3-6.1sarge1.

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.

Exploit likelihood

1.36%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.

Record
CVE-2006-2832
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.

Record
CVE-2006-2832
Updated
2026-11-02
EUVDEUVD-2006-2829 No score

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.

Record
EUVD-2006-2829
Updated
2026-11-03
GitHub AdvisoriesGHSA-vf6r-36v5-6m37 No score

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x...

Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.

Record
GHSA-vf6r-36v5-6m37
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal
Debian:3.1
before 4.5.3-6.1sarge1, plus listed versions
4.5.3-24.5.3-34.5.3-44.5.3-54.5.3-6
4.5.3-6.1sarge1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open