CVE-2006-2832
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x...
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.
Exploit likelihood
What each source reports
NVD Score used
2.6
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.
- Record
CVE-2006-2832- CVSS 2.0
- 2.6 Low
AV:N/AC:H/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.
- Record
CVE-2006-2832- Updated
- 2026-11-02
EUVDEUVD-2006-2829 No score
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.
- Record
EUVD-2006-2829- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vf6r-36v5-6m37 No score
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x...
Cross-site scripting (XSS) vulnerability in the upload module (upload.module) in Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2 allows remote attackers to inject arbitrary web script or HTML via the uploaded filename.
- Record
GHSA-vf6r-36v5-6m37- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupalDebian:3.1 |
before 4.5.3-6.1sarge1, plus listed versions 4.5.3-24.5.3-34.5.3-44.5.3-54.5.3-6 |
4.5.3-6.1sarge1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-2832 is a low vulnerability (CVSS 2.6) in Drupal, published June 6, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in drupal 4.5.3-6.1sarge1.
References
securityfocus.com/bid/18245
securityfocus.com/archive/1/435792/100/0/threaded
debian.org/security/2006/dsa-1125
secunia.com/advisories/21244
drupal.org/node/66763
securityreason.com/securityalert/1042
drupal.org/files/sa-2006-007/advisory.txt
nvd.nist.gov/vuln/detail/CVE-2006-2832
github.com/advisories/GHSA-vf6r-36v5-6m37