Every CVE Search/ Get API key

CVE-2008-2149

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow...

7.5 HighFix available

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Exploit likelihood

4.09%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
CVE-2008-2149
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
CVE-2008-2149
Updated
2026-11-02
EUVDEUVD-2008-2146 No score

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
EUVD-2008-2146
Updated
2026-11-03
GitHub AdvisoriesGHSA-4hrh-x42w-7jw8 No score

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow...

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
GHSA-4hrh-x42w-7jw8
Weakness
CWE-119
Updated
2026-11-02
OSVAZL-37060 No score

CVE-2008-2149 affecting package wordnet for versions less than 3.0-43

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
AZL-37060
Updated
2026-11-05
OSVAZL-7422 No score

CVE-2008-2149 affecting package wordnet for versions less than 3.0-38

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
AZL-7422
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
CVE-2008-2149
Updated
2026-11-02
OSVDEBIAN-CVE-2008-2149 No score

Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Record
DEBIAN-CVE-2008-2149
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordnet
Azure Linux:3
before 3.0-43
3.0-43
wordnet
Azure Linux:2
before 3.0-38
3.0-38
wordnet
Debian:12
before 1:3.0-10
1:3.0-10
wordnet
Debian:13
before 1:3.0-10
1:3.0-10
wordnet
Debian:14
before 1:3.0-10
1:3.0-10
wordnet
Debian:4.0
From an advisory covering 2 CVEs
before 1:2.1-4+etch1, plus listed versions
1:2.1-4
1:2.1-4+etch1

History

History
RecordedChangedSources
affected
factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-2149 is a high vulnerability (CVSS 7.5) in Wordnet, published May 12, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.09%, the 90th percentile. Fixed in wordnet 3.0-43.

References

Show 7 moreShow less
MoveEnter Open