Every CVE Search/ Get API key

CVE-2008-4796

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1)...

10.0 HighFix available

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Exploit likelihood

8.98%Up 5.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
CVE-2008-4796
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
CVE-2008-4796
Updated
2026-11-02
EUVDEUVD-2008-4775 No score

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
EUVD-2008-4775
Updated
2026-11-03
GitHub AdvisoriesGHSA-g42h-8ph9-jmvx No score

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1)...

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
GHSA-g42h-8ph9-jmvx
Weakness
CWE-78
Updated
2026-11-02
OSV No score

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
CVE-2008-4796
Updated
2026-11-02
OSVDEBIAN-CVE-2008-4796 No score

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

Record
DEBIAN-CVE-2008-4796
Updated
2026-11-02
OSVopenSUSE-SU-2024:11073-1 No score

nagios-4.4.6-2.5 on GA media

These are all security issues fixed in the nagios-4.4.6-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11073-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libphp-snoopy
Debian:12
before 1.2.4-1
1.2.4-1
wordpress
Debian:12
before 2.5.1-9
2.5.1-9
wordpress
Debian:13
before 2.5.1-9
2.5.1-9
wordpress
Debian:14
before 2.5.1-9
2.5.1-9
moodle
Debian:4.0
before 1.6.3-2+etch1, plus listed versions
1.6.3-2
1.6.3-2+etch1
wordpress
Debian:4.0
before 2.0.10-1etch4, plus listed versions
2.0.10-12.0.10-1etch12.0.10-1etch22.0.10-1etch32.0.10-1~bpo.12.0.9-1
2.0.10-1etch4
wordpress
Debian:5.0
before 2.5.1-11+lenny1, plus listed versions
2.5.1-11
2.5.1-11+lenny1
wordpress
Debian:4.0
before 2.0.10-1etch5, plus listed versions
2.0.10-12.0.10-1etch12.0.10-1etch22.0.10-1etch32.0.10-1etch42.0.10-1~bpo.12.0.9-1
2.0.10-1etch5
nagios
openSUSE:Tumbleweed
before 4.4.6-2.5
4.4.6-2.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-4796 is a high vulnerability (CVSS 10.0) in Snoopy Project Snoopy, published October 30, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.98%, the 95th percentile. Fixed in libphp-snoopy 1.2.4-1.

References

Show 27 moreShow less
MoveEnter Open