Every CVE Search/ Get API key

CVE-2008-1502

Moodle vulnerable to Cross-site scripting

4.3 MediumFix available

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Exploit likelihood

10.5%Up 6.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
CVE-2008-1502
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
CVE-2008-1502
Updated
2026-11-02
EUVDEUVD-2022-5304 No score

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
EUVD-2022-5304
Updated
2026-11-03
GitHub AdvisoriesGHSA-v759-3wr5-p294 No score

Moodle vulnerable to Cross-site scripting

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
GHSA-v759-3wr5-p294
Weakness
CWE-79
Updated
2026-11-02
OSV No score

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
CVE-2008-1502
Updated
2026-11-02
OSVDEBIAN-CVE-2008-1502 No score

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
DEBIAN-CVE-2008-1502
Updated
2026-11-02
OSVGHSA-v759-3wr5-p294 No score

Moodle vulnerable to Cross-site scripting

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

Record
GHSA-v759-3wr5-p294
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 1.8.5
1.8.5
wordpress
Debian:12
before 2.5.0-1
2.5.0-1
wordpress
Debian:13
before 2.5.0-1
2.5.0-1
wordpress
Debian:14
before 2.5.0-1
2.5.0-1
moodle
Debian:4.0
From an advisory covering 9 CVEs
before 1.6.3-2+etch1, plus listed versions
1.6.3-2
1.6.3-2+etch1
wordpress
Debian:4.0
From an advisory covering 11 CVEs
before 2.0.10-1etch4, plus listed versions
2.0.10-12.0.10-1etch12.0.10-1etch22.0.10-1etch32.0.10-1~bpo.12.0.9-1
2.0.10-1etch4
wordpress
Debian:5.0
From an advisory covering 11 CVEs
before 2.5.1-11+lenny1, plus listed versions
2.5.1-11
2.5.1-11+lenny1
wordpress
Debian:4.0
From an advisory covering 11 CVEs
before 2.0.10-1etch5, plus listed versions
2.0.10-12.0.10-1etch12.0.10-1etch22.0.10-1etch32.0.10-1etch42.0.10-1~bpo.12.0.9-1
2.0.10-1etch5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-1502 is a medium vulnerability (CVSS 4.3) in Egroupware, published March 25, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.5%, the 95th percentile. Fixed in moodle/moodle 1.8.5.

References

Show 28 moreShow less
MoveEnter Open