CVE-2009-0737
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php)...
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
2.6
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2009-0737- CVSS 2.0
- 2.6 Low
AV:N/AC:H/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2009-0737- Updated
- 2026-11-02
EUVDEUVD-2009-0737 No score
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2009-0737- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qxxc-64qv-jfrg No score
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php)...
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-qxxc-64qv-jfrg- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2009-0737- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-0737 No score
Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
DEBIAN-CVE-2009-0737- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.14.0-1 | 1:1.14.0-1 |
mediawikiDebian:13 |
before 1:1.14.0-1 | 1:1.14.0-1 |
mediawikiDebian:14 |
before 1:1.14.0-1 | 1:1.14.0-1 |
mediawiki1.7Debian:4.0 From an advisory covering 4 CVEs |
before 1.7.1-9etch1, plus listed versions 1.7.1-9etch0 |
1.7.1-9etch1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-0737 is a low vulnerability (CVSS 2.6) in Mediawiki, published February 25, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 74th percentile. Fixed in mediawiki 1:1.14.0-1.
References
svn.wikimedia.org/svnroot/mediawiki/tags/REL1_6_12/phase3/RELEASE-NOTES
debian.org/security/2009/dsa-1901
secunia.com/advisories/33881
svn.wikimedia.org/svnroot/mediawiki/tags/REL1_12_4/phase3/RELEASE-NOTES
lists.wikimedia.org/pipermail/mediawiki-announce/2009-February/000083.html
securityfocus.com/bid/33681