Every CVE Search/ Get API key

CVE-2009-0737

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php)...

2.6 LowFix available

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

1.48%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2009-0737
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2009-0737
Updated
2026-11-02
EUVDEUVD-2009-0737 No score

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2009-0737
Updated
2026-11-03
GitHub AdvisoriesGHSA-qxxc-64qv-jfrg No score

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php)...

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-qxxc-64qv-jfrg
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2009-0737
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0737 No score

Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
DEBIAN-CVE-2009-0737
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.14.0-1
1:1.14.0-1
mediawiki
Debian:13
before 1:1.14.0-1
1:1.14.0-1
mediawiki
Debian:14
before 1:1.14.0-1
1:1.14.0-1
mediawiki1.7
Debian:4.0
From an advisory covering 4 CVEs
before 1.7.1-9etch1, plus listed versions
1.7.1-9etch0
1.7.1-9etch1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0737 is a low vulnerability (CVSS 2.6) in Mediawiki, published February 25, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 74th percentile. Fixed in mediawiki 1:1.14.0-1.

References

Show 5 moreShow less
MoveEnter Open