Every CVE Search/ Get API key

CVE-2009-1273

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates...

5.0 MediumFix available

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Exploit likelihood

1.31%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
CVE-2009-1273
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-255
Updated
2026-11-02
CVE List No score

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
CVE-2009-1273
Updated
2026-11-02
EUVDEUVD-2009-1272 No score

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
EUVD-2009-1272
Updated
2026-11-03
GitHub AdvisoriesGHSA-hcjw-5x4c-67px No score

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates...

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
GHSA-hcjw-5x4c-67px
Updated
2026-11-02
OSV No score

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
CVE-2009-1273
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1273 No score

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

Record
DEBIAN-CVE-2009-1273
Updated
2026-11-02
OSVopenSUSE-SU-2024:10464-1 No score

pam_ssh-2.1-1.7 on GA media

These are all security issues fixed in the pam_ssh-2.1-1.7 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10464-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpam-ssh
Debian:13
before 1.92-7
1.92-7
libpam-ssh
Debian:14
before 1.92-7
1.92-7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1273 is a medium vulnerability (CVSS 5.0) in Andrew J.korty Pam Ssh, published April 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in libpam-ssh 1.92-7.

References

MoveEnter Open