CVE-2009-1273
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates...
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
Exploit likelihood
What each source reports
NVD Score used
5.0
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
CVE-2009-1273- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-255
- Updated
- 2026-11-02
CVE List No score
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
CVE-2009-1273- Updated
- 2026-11-02
EUVDEUVD-2009-1272 No score
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
EUVD-2009-1272- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hcjw-5x4c-67px No score
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates...
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
GHSA-hcjw-5x4c-67px- Updated
- 2026-11-02
OSV No score
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
CVE-2009-1273- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-1273 No score
pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.
- Record
DEBIAN-CVE-2009-1273- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10464-1 No score
pam_ssh-2.1-1.7 on GA media
These are all security issues fixed in the pam_ssh-2.1-1.7 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10464-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libpam-sshDebian:13 |
before 1.92-7 | 1.92-7 |
libpam-sshDebian:14 |
before 1.92-7 | 1.92-7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-1273 is a medium vulnerability (CVSS 5.0) in Andrew J.korty Pam Ssh, published April 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in libpam-ssh 1.92-7.
References
bugs.gentoo.org/show_bug.cgi?id=263579
secunia.com/advisories/34986
secunia.com/advisories/34536
redhat.com/archives/fedora-package-announce/2009-May/msg00116.html
redhat.com/archives/fedora-package-announce/2009-May/msg00145.html
nvd.nist.gov/vuln/detail/CVE-2009-1273
github.com/advisories/GHSA-hcjw-5x4c-67px
security-tracker.debian.org/tracker/CVE-2009-1273
suse.com/security/cve/CVE-2009-1273