Every CVE Search/ Get API key

CVE-2009-1720

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause...

7.5 HighFix available

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Exploit likelihood

6.44%Up 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-1720
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-1720
Updated
2026-11-02
EUVDEUVD-2009-1715 No score

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
EUVD-2009-1715
Updated
2026-11-03
GitHub AdvisoriesGHSA-9qfx-pcxp-2cw7 No score

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause...

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
GHSA-9qfx-pcxp-2cw7
Updated
2026-11-02
OSV No score

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-1720
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1720 No score

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

Record
DEBIAN-CVE-2009-1720
Updated
2026-11-02
OSVopenSUSE-SU-2024:10160-1 No score

libIlmImf-2_2-22-2.2.0-1.8 on GA media

These are all security issues fixed in the libIlmImf-2_2-22-2.2.0-1.8 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10160-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openexr
Debian:12
before 1.6.1-4.1
1.6.1-4.1
openexr
Debian:13
before 1.6.1-4.1
1.6.1-4.1
openexr
Debian:14
before 1.6.1-4.1
1.6.1-4.1
openexr
Debian:4.0
From an advisory covering 3 CVEs
before 1.2.2-4.3+etch2, plus listed versions
1.2.2-4.3
1.2.2-4.3+etch2
openexr
Debian:5.0
From an advisory covering 3 CVEs
before 1.6.1-3+lenny3, plus listed versions
1.6.1-3
1.6.1-3+lenny3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1720 is a high vulnerability (CVSS 7.5) in Openexr, published July 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.44%, the 93rd percentile. Fixed in openexr 1.6.1-4.1.

References

Show 22 moreShow less
MoveEnter Open