CVE-2009-1720
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause...
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-1720- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-189
- Updated
- 2026-11-02
CVE List No score
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-1720- Updated
- 2026-11-02
EUVDEUVD-2009-1715 No score
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
EUVD-2009-1715- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9qfx-pcxp-2cw7 No score
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause...
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
GHSA-9qfx-pcxp-2cw7- Updated
- 2026-11-02
OSV No score
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-1720- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-1720 No score
Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.
- Record
DEBIAN-CVE-2009-1720- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10160-1 No score
libIlmImf-2_2-22-2.2.0-1.8 on GA media
These are all security issues fixed in the libIlmImf-2_2-22-2.2.0-1.8 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10160-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openexrDebian:12 |
before 1.6.1-4.1 | 1.6.1-4.1 |
openexrDebian:13 |
before 1.6.1-4.1 | 1.6.1-4.1 |
openexrDebian:14 |
before 1.6.1-4.1 | 1.6.1-4.1 |
openexrDebian:4.0 From an advisory covering 3 CVEs |
before 1.2.2-4.3+etch2, plus listed versions 1.2.2-4.3 |
1.2.2-4.3+etch2 |
openexrDebian:5.0 From an advisory covering 3 CVEs |
before 1.6.1-3+lenny3, plus listed versions 1.6.1-3 |
1.6.1-3+lenny3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-1720 is a high vulnerability (CVSS 7.5) in Openexr, published July 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.44%, the 93rd percentile. Fixed in openexr 1.6.1-4.1.
References
redhat.com/archives/fedora-package-announce/2009-July/msg01286.html
support.apple.com/kb/HT3757
secunia.com/advisories/36123
redhat.com/archives/fedora-package-announce/2009-July/msg01290.html
mandriva.com/security/advisories?name=MDVSA-2009:191
security.debian.org/pool/updates/main/o/openexr/openexr_1.2.2-4.3+etch2.diff.gz
Show 22 moreShow less
secunia.com/advisories/36753
vupen.com/english/advisories/2009/2035
secunia.com/advisories/36096
debian.org/security/2009/dsa-1842
mandriva.com/security/advisories?name=MDVSA-2009:190
secunia.com/advisories/36030
secunia.com/advisories/36032
lists.apple.com/archives/security-announce/2009/Aug/msg00001.html
security.debian.org/pool/updates/main/o/openexr/openexr_1.6.1-3+lenny3.diff.gz
release.debian.org/proposed-updates/stable_diffs/openexr_1.6.1-3%2Blenny3.debdiff
securityfocus.com/bid/35838
securitytracker.com/id?1022674
ubuntu.com/usn/USN-831-1
vupen.com/english/advisories/2009/2172
us-cert.gov/cas/techalerts/TA09-218A.html
lists.opensuse.org/opensuse-security-announce/2009-09/msg00000.html
github.com/openexr/openexr/blob/master/CHANGES.md
nvd.nist.gov/vuln/detail/CVE-2009-1720
github.com/advisories/GHSA-9qfx-pcxp-2cw7
security-tracker.debian.org/tracker/CVE-2009-1720
suse.com/security/cve/CVE-2009-1720
suse.com/security/cve/CVE-2009-1721