Every CVE Search/ Get API key

CVE-2009-2432

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information...

5.0 MediumFix available

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Exploit likelihood

3.08%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
CVE-2009-2432
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
CVE-2009-2432
Updated
2026-11-02
EUVDEUVD-2009-2427 No score

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
EUVD-2009-2427
Updated
2026-11-03
GitHub AdvisoriesGHSA-5x2f-7539-frwf No score

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information...

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
GHSA-5x2f-7539-frwf
Updated
2026-11-02
OSV No score

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
CVE-2009-2432
Updated
2026-11-02
OSVDEBIAN-CVE-2009-2432 No score

WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.

Record
DEBIAN-CVE-2009-2432
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 2.8.3-1
2.8.3-1
wordpress
Debian:13
before 2.8.3-1
2.8.3-1
wordpress
Debian:14
before 2.8.3-1
2.8.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-2432 is a medium vulnerability (CVSS 5.0) in Wordpress, published July 10, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.08%, the 87th percentile. Fixed in wordpress 2.8.3-1.

References

MoveEnter Open