CVE-2009-2432
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information...
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
Exploit likelihood
What each source reports
NVD Score used
5.0
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
CVE-2009-2432- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
CVE-2009-2432- Updated
- 2026-11-02
EUVDEUVD-2009-2427 No score
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
EUVD-2009-2427- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5x2f-7539-frwf No score
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information...
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
GHSA-5x2f-7539-frwf- Updated
- 2026-11-02
OSV No score
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
CVE-2009-2432- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-2432 No score
WordPress and WordPress MU before 2.8.1 allow remote attackers to obtain sensitive information via a direct request to wp-settings.php, which reveals the installation path in an error message.
- Record
DEBIAN-CVE-2009-2432- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-2432 is a medium vulnerability (CVSS 5.0) in Wordpress, published July 10, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.08%, the 87th percentile. Fixed in wordpress 2.8.3-1.
References
corelabs.coresecurity.com/index.php?action=view&type=advisory&name=WordPress_Privileges_Unchecked
securityfocus.com/archive/1/504795/100/0/threaded
securitytracker.com/id?1022528
vupen.com/english/advisories/2009/1833
exchange.xforce.ibmcloud.com/vulnerabilities/51734
osvdb.org/55717
nvd.nist.gov/vuln/detail/CVE-2009-2432
github.com/advisories/GHSA-5x2f-7539-frwf
security-tracker.debian.org/tracker/CVE-2009-2432