Every CVE Search/ Get API key

CVE-2009-3009

Cross site scripting that affects rails

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Exploit likelihood

3.02%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
CVE-2009-3009
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
CVE-2009-3009
Updated
2026-11-02
EUVDEUVD-2017-0194 No score

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
EUVD-2017-0194
Updated
2026-11-03
GitHub AdvisoriesGHSA-8qrh-h9m2-5fvf No score

Cross site scripting that affects rails

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
GHSA-8qrh-h9m2-5fvf
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
CVE-2009-3009
Updated
2026-11-02
OSVDEBIAN-CVE-2009-3009 No score

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
DEBIAN-CVE-2009-3009
Updated
2026-11-02
OSVGHSA-8qrh-h9m2-5fvf No score

Cross site scripting that affects rails

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Record
GHSA-8qrh-h9m2-5fvf
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
actionpack
RubyGems
2.0.0 up to 2.2.3
2.2.3
actionpack
RubyGems
2.3.0 up to 2.3.4
2.3.4
activesupport
RubyGems
2.0.0 up to 2.2.3
2.2.3
activesupport
RubyGems
2.3.0 up to 2.3.4
2.3.4
rails
Debian:12
before 2.2.3-1
2.2.3-1
rails
Debian:13
before 2.2.3-1
2.2.3-1
rails
Debian:14
before 2.2.3-1
2.2.3-1
rails
Debian:5.0
before 2.1.0-7, plus listed versions
2.1.0-6
2.1.0-7
actionpack
RubyGems
2.0.0 up to 2.2.3, plus listed versions
2.0.12.0.22.0.42.0.52.1.02.1.12.1.22.2.2
2.2.3
actionpack
RubyGems
2.3.0 up to 2.3.4, plus listed versions
2.3.22.3.3
2.3.4
activesupport
RubyGems
2.0.0 up to 2.2.3, plus listed versions
2.0.12.0.22.0.42.0.52.1.02.1.12.1.22.2.2
2.2.3
activesupport
RubyGems
2.3.0 up to 2.3.4, plus listed versions
2.3.22.3.3
2.3.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-3009 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published September 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.02%, the 87th percentile. Fixed in actionpack 2.2.3.

References

Show 12 moreShow less
MoveEnter Open