CVE-2009-3009
Cross site scripting that affects rails
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
CVE-2009-3009- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
CVE-2009-3009- Updated
- 2026-11-02
EUVDEUVD-2017-0194 No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
EUVD-2017-0194- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8qrh-h9m2-5fvf No score
Cross site scripting that affects rails
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
GHSA-8qrh-h9m2-5fvf- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
CVE-2009-3009- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-3009 No score
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
DEBIAN-CVE-2009-3009- Updated
- 2026-11-02
OSVGHSA-8qrh-h9m2-5fvf No score
Cross site scripting that affects rails
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
- Record
GHSA-8qrh-h9m2-5fvf- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
actionpackRubyGems |
2.0.0 up to 2.2.3 | 2.2.3 |
actionpackRubyGems |
2.3.0 up to 2.3.4 | 2.3.4 |
activesupportRubyGems |
2.0.0 up to 2.2.3 | 2.2.3 |
activesupportRubyGems |
2.3.0 up to 2.3.4 | 2.3.4 |
railsDebian:12 |
before 2.2.3-1 | 2.2.3-1 |
railsDebian:13 |
before 2.2.3-1 | 2.2.3-1 |
railsDebian:14 |
before 2.2.3-1 | 2.2.3-1 |
railsDebian:5.0 |
before 2.1.0-7, plus listed versions 2.1.0-6 |
2.1.0-7 |
actionpackRubyGems |
2.0.0 up to 2.2.3, plus listed versions 2.0.12.0.22.0.42.0.52.1.02.1.12.1.22.2.2 |
2.2.3 |
actionpackRubyGems |
2.3.0 up to 2.3.4, plus listed versions 2.3.22.3.3 |
2.3.4 |
activesupportRubyGems |
2.0.0 up to 2.2.3, plus listed versions 2.0.12.0.22.0.42.0.52.1.02.1.12.1.22.2.2 |
2.2.3 |
activesupportRubyGems |
2.3.0 up to 2.3.4, plus listed versions 2.3.22.3.3 |
2.3.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-3009 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published September 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.02%, the 87th percentile. Fixed in actionpack 2.2.3.
References
securityfocus.com/bid/36278
weblog.rubyonrails.org/2009/9/4/xss-vulnerability-in-ruby-on-rails
secunia.com/advisories/36600
lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
vupen.com/english/advisories/2009/2544
exchange.xforce.ibmcloud.com/vulnerabilities/53036
Show 12 moreShow less
support.apple.com/kb/HT4077
debian.org/security/2009/dsa-1887
groups.google.com/group/rubyonrails-security/msg/7f57cd7794e1d1b4?dmode=source
bugs.debian.org/cgi-bin/bugreport.cgi?bug=545063
osvdb.org/57666
securitytracker.com/id?1022824
secunia.com/advisories/36717
lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html
nvd.nist.gov/vuln/detail/CVE-2009-3009
github.com/advisories/GHSA-8qrh-h9m2-5fvf
github.com/rubysec/ruby-advisory-db/blob/master/gems/activesupport/CVE-2009-3009.yml
security-tracker.debian.org/tracker/CVE-2009-3009