CVE-2009-3459
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9...
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.
Exploit likelihood
What each source reports
CVE List
8.8
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-3459- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2009-3441
8.8
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.
- Record
EUVD-2009-3441- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-q52p-3m33-w676
8.8
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9...
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.
- Record
GHSA-q52p-3m33-w676- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-122
- Updated
- 2026-11-02
CISA KEV No score
Adobe Acrobat and Reader Heap-Based Buffer Overflow Vulnerability
Adobe Acrobat and Reader contain a heap-based buffer overflow vulnerability which could allow remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption.
- Record
CVE-2009-3459- Weakness
- CWE-119
- Updated
- 2026-11-02
NVD
8.8
Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-3459- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-119, CWE-122
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
acroreadRed Hat:rhel_extras:3 |
before 0:8.1.7-1 | 0:8.1.7-1 |
acroread-pluginRed Hat:rhel_extras:3 |
before 0:8.1.7-1 | 0:8.1.7-1 |
acroreadRed Hat:rhel_extras:4 |
before 0:8.1.7-1.el4 | 0:8.1.7-1.el4 |
acroread-pluginRed Hat:rhel_extras:4 |
before 0:8.1.7-1.el4 | 0:8.1.7-1.el4 |
acroreadRed Hat:rhel_extras:5::client |
before 0:8.1.7-1.el5 | 0:8.1.7-1.el5 |
acroread-pluginRed Hat:rhel_extras:5::client |
before 0:8.1.7-1.el5 | 0:8.1.7-1.el5 |
acroreadRed Hat:rhel_extras:5::server |
before 0:8.1.7-1.el5 | 0:8.1.7-1.el5 |
acroread-pluginRed Hat:rhel_extras:5::server |
before 0:8.1.7-1.el5 | 0:8.1.7-1.el5 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | Adobe FlateDecode Stream Predictor 02 Integer Overflow | 2009-10-08 |
| Metasploit | Adobe FlateDecode Stream Predictor 02 Integer Overflow | 2009-10-08 |
| Exploit-DB | Adobe - FlateDecode Stream Predictor 02 Integer Overflow (Metasploit) (1) | 2010-09-20 |
| Exploit-DB | Adobe - FlateDecode Stream Predictor 02 Integer Overflow (Metasploit) (2) | 2010-09-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| exploitation, exploits | ||
| first indexed | CVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-3459 is a high vulnerability (CVSS 9.3) in Adobe Acrobat, published October 13, 2009. CISA lists it as known to be exploited, since May 20, 2026. EUVD reports exploitation since May 20, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 86.5%, the 99th percentile. Fixed in acroread 0:8.1.7-1.
References
secunia.com/advisories/36983
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6534
us-cert.gov/cas/techalerts/TA09-286B.html
securitytracker.com/id?1023007
adobe.com/support/security/bulletins/apsb09-15.html
iss.net/threats/348.html
Show 70 moreShow less
vupen.com/english/advisories/2009/2851
isc.sans.org/diary.html?storyid=7300
blogs.adobe.com/psirt/2009/10/adobe_reader_and_acrobat_issue_1.html
securityfocus.com/bid/36600
vupen.com/english/advisories/2009/2898
exchange.xforce.ibmcloud.com/vulnerabilities/53691
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2009-3459
nvd.nist.gov/vuln/detail/CVE-2009-3459
github.com/advisories/GHSA-q52p-3m33-w676
access.redhat.com/errata/RHSA-2009:1499
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=528071
bugzilla.redhat.com/show_bug.cgi?id=528659
bugzilla.redhat.com/show_bug.cgi?id=528665
bugzilla.redhat.com/show_bug.cgi?id=528666
security.access.redhat.com/data/csaf/v2/advisories/2009/rhsa-2009_1499.json
access.redhat.com/security/cve/CVE-2009-2979
cve.org/CVERecord?id=CVE-2009-2979
nvd.nist.gov/vuln/detail/CVE-2009-2979
access.redhat.com/security/cve/CVE-2009-2980
cve.org/CVERecord?id=CVE-2009-2980
nvd.nist.gov/vuln/detail/CVE-2009-2980
access.redhat.com/security/cve/CVE-2009-2981
cve.org/CVERecord?id=CVE-2009-2981
nvd.nist.gov/vuln/detail/CVE-2009-2981
access.redhat.com/security/cve/CVE-2009-2983
cve.org/CVERecord?id=CVE-2009-2983
nvd.nist.gov/vuln/detail/CVE-2009-2983
access.redhat.com/security/cve/CVE-2009-2985
cve.org/CVERecord?id=CVE-2009-2985
nvd.nist.gov/vuln/detail/CVE-2009-2985
access.redhat.com/security/cve/CVE-2009-2986
cve.org/CVERecord?id=CVE-2009-2986
nvd.nist.gov/vuln/detail/CVE-2009-2986
access.redhat.com/security/cve/CVE-2009-2988
cve.org/CVERecord?id=CVE-2009-2988
nvd.nist.gov/vuln/detail/CVE-2009-2988
access.redhat.com/security/cve/CVE-2009-2990
cve.org/CVERecord?id=CVE-2009-2990
nvd.nist.gov/vuln/detail/CVE-2009-2990
access.redhat.com/security/cve/CVE-2009-2991
cve.org/CVERecord?id=CVE-2009-2991
nvd.nist.gov/vuln/detail/CVE-2009-2991
access.redhat.com/security/cve/CVE-2009-2993
cve.org/CVERecord?id=CVE-2009-2993
nvd.nist.gov/vuln/detail/CVE-2009-2993
access.redhat.com/security/cve/CVE-2009-2994
cve.org/CVERecord?id=CVE-2009-2994
nvd.nist.gov/vuln/detail/CVE-2009-2994
access.redhat.com/security/cve/CVE-2009-2996
cve.org/CVERecord?id=CVE-2009-2996
nvd.nist.gov/vuln/detail/CVE-2009-2996
access.redhat.com/security/cve/CVE-2009-2997
cve.org/CVERecord?id=CVE-2009-2997
nvd.nist.gov/vuln/detail/CVE-2009-2997
access.redhat.com/security/cve/CVE-2009-2998
cve.org/CVERecord?id=CVE-2009-2998
nvd.nist.gov/vuln/detail/CVE-2009-2998
access.redhat.com/security/cve/CVE-2009-3431
cve.org/CVERecord?id=CVE-2009-3431
nvd.nist.gov/vuln/detail/CVE-2009-3431
access.redhat.com/security/cve/CVE-2009-3458
cve.org/CVERecord?id=CVE-2009-3458
nvd.nist.gov/vuln/detail/CVE-2009-3458
access.redhat.com/security/cve/CVE-2009-3459
cve.org/CVERecord?id=CVE-2009-3459
cisa.gov/known-exploited-vulnerabilities-catalog
access.redhat.com/security/cve/CVE-2009-3462
cve.org/CVERecord?id=CVE-2009-3462
nvd.nist.gov/vuln/detail/CVE-2009-3462