Every CVE Search/ Get API key

CVE-2009-3459

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9...

9.3 HighIn KEVPublic exploitFix available

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Exploit likelihood

86.5%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List 8.8

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-3459
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2009-3441 8.8

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Record
EUVD-2009-3441
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-q52p-3m33-w676 8.8

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9...

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Record
GHSA-q52p-3m33-w676
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-122
Updated
2026-11-02
CISA KEV No score

Adobe Acrobat and Reader Heap-Based Buffer Overflow Vulnerability

Adobe Acrobat and Reader contain a heap-based buffer overflow vulnerability which could allow remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption.

Record
CVE-2009-3459
Weakness
CWE-119
Updated
2026-11-02
NVD 8.8

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-3459
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119, CWE-122
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
acroread
Red Hat:rhel_extras:3
before 0:8.1.7-1
0:8.1.7-1
acroread-plugin
Red Hat:rhel_extras:3
before 0:8.1.7-1
0:8.1.7-1
acroread
Red Hat:rhel_extras:4
before 0:8.1.7-1.el4
0:8.1.7-1.el4
acroread-plugin
Red Hat:rhel_extras:4
before 0:8.1.7-1.el4
0:8.1.7-1.el4
acroread
Red Hat:rhel_extras:5::client
before 0:8.1.7-1.el5
0:8.1.7-1.el5
acroread-plugin
Red Hat:rhel_extras:5::client
before 0:8.1.7-1.el5
0:8.1.7-1.el5
acroread
Red Hat:rhel_extras:5::server
before 0:8.1.7-1.el5
0:8.1.7-1.el5
acroread-plugin
Red Hat:rhel_extras:5::server
before 0:8.1.7-1.el5
0:8.1.7-1.el5

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
exploitation, exploits
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-3459 is a high vulnerability (CVSS 9.3) in Adobe Acrobat, published October 13, 2009. CISA lists it as known to be exploited, since May 20, 2026. EUVD reports exploitation since May 20, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 86.5%, the 99th percentile. Fixed in acroread 0:8.1.7-1.

References

Show 70 moreShow less
MoveEnter Open