CVE-2010-3933
Rails activerecord gem has Improper Input Validation vulnerability
CVE-2010-3933 is a medium vulnerability (CVSS 6.4) in Rubyonrails Rails, published October 27, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in activerecord 2.3.10.
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
Exploit likelihood
What each source reports
NVD Score used
6.4
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
- Record
CVE-2010-3933- CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
- Record
CVE-2010-3933- Updated
- 2026-11-02
EUVDEUVD-2017-0240 No score
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
- Record
EUVD-2017-0240- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gjxw-5w2q-7grf No score
Rails activerecord gem has Improper Input Validation vulnerability
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
- Record
GHSA-gjxw-5w2q-7grf- Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-gjxw-5w2q-7grf No score
Rails activerecord gem has Improper Input Validation vulnerability
Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.
- Record
GHSA-gjxw-5w2q-7grf- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
activerecordRubyGems |
2.3.9 up to 2.3.10 | 2.3.10 |
activerecordRubyGems |
3.0.0 up to 3.0.1 | 3.0.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
vupen.com/english/advisories/2010/2719
secunia.com/advisories/41930
securitytracker.com/id?1024624
weblog.rubyonrails.org/2010/10/15/security-vulnerability-in-nested-attributes-code-in-ruby-on-rails-2-3-9-and-3-0-0
nvd.nist.gov/vuln/detail/CVE-2010-3933
github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2010-3933.yml
Show 7 moreShow less
web.archive.org/web/20101129225633/http://securitytracker.com/alerts/2010/Oct/1024624.html
github.com/rails/rails/commit/2d96bccb1e8b62e3e11ca0c5d38aaa8cece889ae
github.com/rails/rails/commit/96183e0f284bab27667e5a38fa6a1578eb029585
web.archive.org/web/20111225083933/http://secunia.com/advisories/41930
web.archive.org/web/20201208053819/http://securitytracker.com/id?1024624
github.com/advisories/GHSA-gjxw-5w2q-7grf
github.com/rails/rails