Every CVE Search/ Get API key

CVE-2010-3933

Rails activerecord gem has Improper Input Validation vulnerability

6.4 MediumFix available

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Exploit likelihood

2.21%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Record
CVE-2010-3933
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:N/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Record
CVE-2010-3933
Updated
2026-11-02
EUVDEUVD-2017-0240 No score

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Record
EUVD-2017-0240
Updated
2026-11-03
GitHub AdvisoriesGHSA-gjxw-5w2q-7grf No score

Rails activerecord gem has Improper Input Validation vulnerability

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Record
GHSA-gjxw-5w2q-7grf
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-gjxw-5w2q-7grf No score

Rails activerecord gem has Improper Input Validation vulnerability

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Record
GHSA-gjxw-5w2q-7grf
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
activerecord
RubyGems
2.3.9 up to 2.3.10
2.3.10
activerecord
RubyGems
3.0.0 up to 3.0.1
3.0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-3933 is a medium vulnerability (CVSS 6.4) in Rubyonrails Rails, published October 27, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in activerecord 2.3.10.

References

Show 7 moreShow less
MoveEnter Open