CVE-2011-1579
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3...
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
Exploit likelihood
What each source reports
NVD Score used
5.8
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
CVE-2011-1579- CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
CVE-2011-1579- Updated
- 2026-11-02
EUVDEUVD-2011-1580 No score
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
EUVD-2011-1580- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rwjq-pqc6-6rcp No score
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3...
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
GHSA-rwjq-pqc6-6rcp- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
CVE-2011-1579- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-1579 No score
The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.
- Record
DEBIAN-CVE-2011-1579- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:13 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:14 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:6.0 From an advisory covering 6 CVEs |
before 1:1.15.5-2squeeze2, plus listed versions 1:1.15.5-21:1.15.5-2squeeze1 |
1:1.15.5-2squeeze2 |
mediawikiDebian:5.0 From an advisory covering 6 CVEs |
before 1:1.12.0-2lenny9, plus listed versions 1:1.12.0-2lenny21:1.12.0-2lenny31:1.12.0-2lenny3~bpo40+11:1.12.0-2lenny41:1.12.0-2lenny51:1.12.0-2lenny61:1.12.0-2lenny71:1.12.0-2lenny8 |
1:1.12.0-2lenny9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1579 is a medium vulnerability (CVSS 5.8) in Mediawiki, published April 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in mediawiki 1:1.15.5-5.
References
lists.fedoraproject.org/pipermail/package-announce/2011-April/058588.html
bugzilla.wikimedia.org/show_bug.cgi?id=28450
vupen.com/english/advisories/2011/0978
mediawiki.org/wiki/Special:Code/MediaWiki/85856
lists.fedoraproject.org/pipermail/package-announce/2011-April/059235.html
securityfocus.com/bid/47354
Show 14 moreShow less
secunia.com/advisories/44142
lists.fedoraproject.org/pipermail/package-announce/2011-April/058910.html
vupen.com/english/advisories/2011/1151
exchange.xforce.ibmcloud.com/vulnerabilities/66738
debian.org/security/2011/dsa-2366
bugzilla.redhat.com/show_bug.cgi?id=696360
lists.wikimedia.org/pipermail/mediawiki-announce/2011-April/000096.html
vupen.com/english/advisories/2011/1100
lists.fedoraproject.org/pipermail/package-announce/2011-April/059232.html
bugzilla.redhat.com/show_bug.cgi?id=695577
openwall.com/lists/oss-security/2011/04/13/15
nvd.nist.gov/vuln/detail/CVE-2011-1579
github.com/advisories/GHSA-rwjq-pqc6-6rcp
security-tracker.debian.org/tracker/CVE-2011-1579