Every CVE Search/ Get API key

CVE-2011-1579

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3...

5.8 MediumFix available

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Exploit likelihood

1.92%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
CVE-2011-1579
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
CVE-2011-1579
Updated
2026-11-02
EUVDEUVD-2011-1580 No score

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
EUVD-2011-1580
Updated
2026-11-03
GitHub AdvisoriesGHSA-rwjq-pqc6-6rcp No score

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3...

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
GHSA-rwjq-pqc6-6rcp
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
CVE-2011-1579
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1579 No score

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Record
DEBIAN-CVE-2011-1579
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:13
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:14
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:6.0
From an advisory covering 6 CVEs
before 1:1.15.5-2squeeze2, plus listed versions
1:1.15.5-21:1.15.5-2squeeze1
1:1.15.5-2squeeze2
mediawiki
Debian:5.0
From an advisory covering 6 CVEs
before 1:1.12.0-2lenny9, plus listed versions
1:1.12.0-2lenny21:1.12.0-2lenny31:1.12.0-2lenny3~bpo40+11:1.12.0-2lenny41:1.12.0-2lenny51:1.12.0-2lenny61:1.12.0-2lenny71:1.12.0-2lenny8
1:1.12.0-2lenny9

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1579 is a medium vulnerability (CVSS 5.8) in Mediawiki, published April 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in mediawiki 1:1.15.5-5.

References

Show 14 moreShow less
MoveEnter Open