Every CVE Search/ Get API key

CVE-2011-2428

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3...

9.3 HighFix available

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

Exploit likelihood

5.25%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

Record
CVE-2011-2428
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

Record
CVE-2011-2428
Updated
2026-11-02
EUVDEUVD-2011-2417 No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

Record
EUVD-2011-2417
Updated
2026-11-03
GitHub AdvisoriesGHSA-8368-8fhr-8jhg No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3...

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

Record
GHSA-8368-8fhr-8jhg
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:5::client
before 0:10.3.183.10-1.el5
0:10.3.183.10-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
before 0:10.3.183.10-1.el5
0:10.3.183.10-1.el5
flash-plugin
Red Hat:rhel_extras:6
before 0:10.3.183.10-1.el6
0:10.3.183.10-1.el6
acroread
Red Hat:rhel_extras:4
before 0:9.4.6-1.el4
0:9.4.6-1.el4
acroread-plugin
Red Hat:rhel_extras:4
before 0:9.4.6-1.el4
0:9.4.6-1.el4
acroread
Red Hat:rhel_extras:5::client
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread-plugin
Red Hat:rhel_extras:5::client
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread
Red Hat:rhel_extras:5::server
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread-plugin
Red Hat:rhel_extras:5::server
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread
Red Hat:rhel_extras:6
before 0:9.4.6-1.el6
0:9.4.6-1.el6
acroread-plugin
Red Hat:rhel_extras:6
before 0:9.4.6-1.el6
0:9.4.6-1.el6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2428 is a high vulnerability (CVSS 9.3) in Adobe Flash Player, published September 22, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.25%, the 92nd percentile. Fixed in flash-plugin 0:10.3.183.10-1.el5.

References

Show 142 moreShow less
MoveEnter Open