Every CVE Search/ Get API key

CVE-2011-2430

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3...

9.3 HighFix available

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows remote attackers to execute arbitrary code via crafted streaming media, related to a "logic error vulnerability."

Exploit likelihood

6.27%Down 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows remote attackers to execute arbitrary code via crafted streaming media, related to a "logic error vulnerability."

Record
CVE-2011-2430
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows remote attackers to execute arbitrary code via crafted streaming media, related to a "logic error vulnerability."

Record
CVE-2011-2430
Updated
2026-11-02
EUVDEUVD-2011-2419 No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows remote attackers to execute arbitrary code via crafted streaming media, related to a "logic error vulnerability."

Record
EUVD-2011-2419
Updated
2026-11-03
GitHub AdvisoriesGHSA-9mj8-c9h5-8r5p No score

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3...

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows remote attackers to execute arbitrary code via crafted streaming media, related to a "logic error vulnerability."

Record
GHSA-9mj8-c9h5-8r5p
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:5::client
before 0:10.3.183.10-1.el5
0:10.3.183.10-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
before 0:10.3.183.10-1.el5
0:10.3.183.10-1.el5
flash-plugin
Red Hat:rhel_extras:6
before 0:10.3.183.10-1.el6
0:10.3.183.10-1.el6
acroread
Red Hat:rhel_extras:4
before 0:9.4.6-1.el4
0:9.4.6-1.el4
acroread-plugin
Red Hat:rhel_extras:4
before 0:9.4.6-1.el4
0:9.4.6-1.el4
acroread
Red Hat:rhel_extras:5::client
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread-plugin
Red Hat:rhel_extras:5::client
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread
Red Hat:rhel_extras:5::server
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread-plugin
Red Hat:rhel_extras:5::server
before 0:9.4.6-1.el5
0:9.4.6-1.el5
acroread
Red Hat:rhel_extras:6
before 0:9.4.6-1.el6
0:9.4.6-1.el6
acroread-plugin
Red Hat:rhel_extras:6
before 0:9.4.6-1.el6
0:9.4.6-1.el6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2430 is a high vulnerability (CVSS 9.3) in Adobe Flash Player, published September 22, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.27%, the 93rd percentile. Fixed in flash-plugin 0:10.3.183.10-1.el5.

References

Show 142 moreShow less
MoveEnter Open