CVE-2011-4299
Moodle vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
- Record
CVE-2011-4299- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
- Record
CVE-2011-4299- Updated
- 2026-11-02
EUVDEUVD-2011-4236 No score
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
- Record
EUVD-2011-4236- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h6px-pvfh-q2jv
1.2
Moodle vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
- Record
GHSA-h6px-pvfh-q2jv- CVSS 4.0
- 1.2 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-h6px-pvfh-q2jv
1.2
Moodle vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
- Record
GHSA-h6px-pvfh-q2jv- CVSS 4.0
- 1.2 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.0.0 up to 2.0.5 | 2.0.5 |
moodle/moodlePackagist |
2.1.0 up to 2.1.2 | 2.1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4299 is a medium vulnerability (CVSS 4.3) in Moodle, published July 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in moodle/moodle 2.0.5.
References
moodle.org/mod/forum/discuss.php?d=188310
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=a459fd90625ae44d7b3ac10b65da2dc631a418e7
bugzilla.redhat.com/show_bug.cgi?id=747444
nvd.nist.gov/vuln/detail/CVE-2011-4299
git.moodle.org/gw?p=moodle.git;a=commit;h=a459fd90625ae44d7b3ac10b65da2dc631a418e7
github.com/advisories/GHSA-h6px-pvfh-q2jv
git.moodle.org