Every CVE Search/ Get API key

CVE-2011-4299

Moodle vulnerable to Cross-Site Scripting

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Exploit likelihood

1.19%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Record
CVE-2011-4299
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Record
CVE-2011-4299
Updated
2026-11-02
EUVDEUVD-2011-4236 No score

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Record
EUVD-2011-4236
Updated
2026-11-03
GitHub AdvisoriesGHSA-h6px-pvfh-q2jv 1.2

Moodle vulnerable to Cross-Site Scripting

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Record
GHSA-h6px-pvfh-q2jv
CVSS 4.0
1.2 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-h6px-pvfh-q2jv 1.2

Moodle vulnerable to Cross-Site Scripting

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Record
GHSA-h6px-pvfh-q2jv
CVSS 4.0
1.2 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.0.0 up to 2.0.5
2.0.5
moodle/moodle
Packagist
2.1.0 up to 2.1.2
2.1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4299 is a medium vulnerability (CVSS 4.3) in Moodle, published July 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in moodle/moodle 2.0.5.

References

MoveEnter Open