CVE-2012-2240
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary...
CVE-2012-2240 is a high vulnerability (CVSS 7.5) in Devscripts Devel Team Devscripts, published September 15, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.15%, the 87th percentile. Fixed in devscripts 2.12.3.
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
Exploit likelihood
What each source reports
NVD Score used
7.5
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
CVE-2012-2240- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
CVE-2012-2240- Updated
- 2026-11-02
EUVDEUVD-2012-2233 No score
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
EUVD-2012-2233- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cx6j-736h-qcc7 No score
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary...
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
GHSA-cx6j-736h-qcc7- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
CVE-2012-2240- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-2240 No score
scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified vectors related to "arguments to external commands."
- Record
DEBIAN-CVE-2012-2240- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10372-1 No score
checkbashisms-2.15.1-1.8 on GA media
These are all security issues fixed in the checkbashisms-2.15.1-1.8 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10372-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
devscriptsDebian:12 |
before 2.12.3 | 2.12.3 |
devscriptsDebian:13 |
before 2.12.3 | 2.12.3 |
devscriptsDebian:14 |
before 2.12.3 | 2.12.3 |
devscriptsDebian:6.0 |
before 2.10.69+squeeze4, plus listed versions 2.10.692.10.69+squeeze12.10.69+squeeze22.10.69+squeeze3 |
2.10.69+squeeze4 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |