CVE-2012-2337
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support...
CVE-2012-2337 is a high vulnerability (CVSS 7.2) in Todd Miller Sudo, published May 18, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in sudo 1.8.3p2-1.1.
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
Exploit likelihood
What each source reports
NVD Score used
7.2
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
CVE-2012-2337- CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
CVE-2012-2337- Updated
- 2026-11-02
EUVDEUVD-2012-2330 No score
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
EUVD-2012-2330- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-69qw-r4p8-f6hq No score
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support...
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
GHSA-69qw-r4p8-f6hq- Updated
- 2026-11-02
OSV No score
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
CVE-2012-2337- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-2337 No score
sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.
- Record
DEBIAN-CVE-2012-2337- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10551-1 No score
sudo-1.8.18p1-1.1 on GA media
These are all security issues fixed in the sudo-1.8.18p1-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10551-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
sudoDebian:12 |
before 1.8.3p2-1.1 | 1.8.3p2-1.1 |
sudoDebian:13 |
before 1.8.3p2-1.1 | 1.8.3p2-1.1 |
sudoDebian:14 |
before 1.8.3p2-1.1 | 1.8.3p2-1.1 |
sudoDebian:6.0 |
before 1.7.4p4-2.squeeze.3, plus listed versions 1.7.4p4-2.squeeze.11.7.4p4-2.squeeze.2 |
1.7.4p4-2.squeeze.3 |
sudoRed Hat:enterprise_linux:5::client |
before 0:1.7.2p1-14.el5_8 | 0:1.7.2p1-14.el5_8 |
sudo-debuginfoRed Hat:enterprise_linux:5::client |
before 0:1.7.2p1-14.el5_8 | 0:1.7.2p1-14.el5_8 |
sudoRed Hat:enterprise_linux:5::server |
before 0:1.7.2p1-14.el5_8 | 0:1.7.2p1-14.el5_8 |
sudo-debuginfoRed Hat:enterprise_linux:5::server |
before 0:1.7.2p1-14.el5_8 | 0:1.7.2p1-14.el5_8 |
sudoRed Hat:enterprise_linux:6::client |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudo-debuginfoRed Hat:enterprise_linux:6::client |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
Show 7 moreShow less
| Package | Affected | Fixed |
|---|---|---|
sudoRed Hat:enterprise_linux:6::computenode |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudo-debuginfoRed Hat:enterprise_linux:6::computenode |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudoRed Hat:enterprise_linux:6::server |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudo-debuginfoRed Hat:enterprise_linux:6::server |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudoRed Hat:enterprise_linux:6::workstation |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudo-debuginfoRed Hat:enterprise_linux:6::workstation |
before 0:1.7.4p5-12.el6_3 | 0:1.7.4p5-12.el6_3 |
sudoopenSUSE:Tumbleweed |
before 1.8.18p1-1.1 | 1.8.18p1-1.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
bugzilla.redhat.com/show_bug.cgi?id=820677
secunia.com/advisories/49219
secunia.com/advisories/49948
secunia.com/advisories/49244
mandriva.com/security/advisories?name=MDVSA-2012:079
secunia.com/advisories/49291
Show 18 moreShow less
debian.org/security/2012/dsa-2478
securitytracker.com/id?1027077
suse.com/security/cve/CVE-2012-2337
lists.fedoraproject.org/pipermail/package-announce/2012-May/081432.html
sudo.ws/sudo/alerts/netmask.html
nvd.nist.gov/vuln/detail/CVE-2012-2337
github.com/advisories/GHSA-69qw-r4p8-f6hq
security-tracker.debian.org/tracker/CVE-2012-2337
access.redhat.com/errata/RHSA-2012:1081
access.redhat.com/security/updates/classification
security.access.redhat.com/data/csaf/v2/advisories/2012/rhsa-2012_1081.json
access.redhat.com/security/cve/CVE-2012-2337
cve.org/CVERecord?id=CVE-2012-2337
suse.com/security/cve/CVE-2010-1163
suse.com/security/cve/CVE-2010-1646
suse.com/security/cve/CVE-2011-0010
suse.com/security/cve/CVE-2013-1775
suse.com/security/cve/CVE-2013-1776