Every CVE Search/ Get API key

CVE-2012-2337

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support...

7.2 HighFix available

CVE-2012-2337 is a high vulnerability (CVSS 7.2) in Todd Miller Sudo, published May 18, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in sudo 1.8.3p2-1.1.

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Exploit likelihood

0.40%Down 4.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
CVE-2012-2337
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
CVE-2012-2337
Updated
2026-11-02
EUVDEUVD-2012-2330 No score

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
EUVD-2012-2330
Updated
2026-11-03
GitHub AdvisoriesGHSA-69qw-r4p8-f6hq No score

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support...

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
GHSA-69qw-r4p8-f6hq
Updated
2026-11-02
OSV No score

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
CVE-2012-2337
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2337 No score

sudo 1.6.x and 1.7.x before 1.7.9p1, and 1.8.x before 1.8.4p5, does not properly support configurations that use a netmask syntax, which allows local users to bypass intended command restrictions in opportunistic circumstances by executing a command on a host that has an IPv4 address.

Record
DEBIAN-CVE-2012-2337
Updated
2026-11-02
OSVopenSUSE-SU-2024:10551-1 No score

sudo-1.8.18p1-1.1 on GA media

These are all security issues fixed in the sudo-1.8.18p1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10551-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sudo
Debian:12
before 1.8.3p2-1.1
1.8.3p2-1.1
sudo
Debian:13
before 1.8.3p2-1.1
1.8.3p2-1.1
sudo
Debian:14
before 1.8.3p2-1.1
1.8.3p2-1.1
sudo
Debian:6.0
before 1.7.4p4-2.squeeze.3, plus listed versions
1.7.4p4-2.squeeze.11.7.4p4-2.squeeze.2
1.7.4p4-2.squeeze.3
sudo
Red Hat:enterprise_linux:5::client
before 0:1.7.2p1-14.el5_8
0:1.7.2p1-14.el5_8
sudo-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.7.2p1-14.el5_8
0:1.7.2p1-14.el5_8
sudo
Red Hat:enterprise_linux:5::server
before 0:1.7.2p1-14.el5_8
0:1.7.2p1-14.el5_8
sudo-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.7.2p1-14.el5_8
0:1.7.2p1-14.el5_8
sudo
Red Hat:enterprise_linux:6::client
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo-debuginfo
Red Hat:enterprise_linux:6::client
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
Show 7 moreShow less
Affected packages
PackageAffectedFixed
sudo
Red Hat:enterprise_linux:6::computenode
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo
Red Hat:enterprise_linux:6::server
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo
Red Hat:enterprise_linux:6::workstation
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:1.7.4p5-12.el6_3
0:1.7.4p5-12.el6_3
sudo
openSUSE:Tumbleweed
before 1.8.18p1-1.1
1.8.18p1-1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 18 moreShow less
MoveEnter Open