Every CVE Search/ Get API key

CVE-2012-4000

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog...

4.3 MediumPublic exploitFix available

CVE-2012-4000 is a medium vulnerability (CVSS 4.3) in Ckeditor Fckeditor, published July 12, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.25%, the 91st percentile. Fixed in fckeditor 1:2.6.6-1squeeze1.

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.

Exploit likelihood

4.25%Up 2.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.

Record
CVE-2012-4000
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.

Record
CVE-2012-4000
Updated
2026-11-02
EUVDEUVD-2012-3944 No score

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.

Record
EUVD-2012-3944
Updated
2026-11-03
GitHub AdvisoriesGHSA-8c32-34gf-q623 No score

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog...

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.

Record
GHSA-8c32-34gf-q623
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fckeditor
Debian:6.0
before 1:2.6.6-1squeeze1, plus listed versions
1:2.6.6-1
1:2.6.6-1squeeze1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBFCKEditor Core - 'Editor 'spellchecker.php' Cross-Site Scripting2012-06-25

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

MoveEnter Open