CVE-2012-4000
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog...
CVE-2012-4000 is a medium vulnerability (CVSS 4.3) in Ckeditor Fckeditor, published July 12, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.25%, the 91st percentile. Fixed in fckeditor 1:2.6.6-1squeeze1.
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.
- Record
CVE-2012-4000- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.
- Record
CVE-2012-4000- Updated
- 2026-11-02
EUVDEUVD-2012-3944 No score
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.
- Record
EUVD-2012-3944- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8c32-34gf-q623 No score
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog...
Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and earlier allows remote attackers to inject arbitrary web script or HTML via textinputs array parameters.
- Record
GHSA-8c32-34gf-q623- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fckeditorDebian:6.0 |
before 1:2.6.6-1squeeze1, plus listed versions 1:2.6.6-1 |
1:2.6.6-1squeeze1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | FCKEditor Core - 'Editor 'spellchecker.php' Cross-Site Scripting | 2012-06-25 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |