CVE-2012-4560
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of...
CVE-2012-4560 is a high vulnerability (CVSS 7.5) in Libssh, published November 30, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.45%, the 93rd percentile. Fixed in libssh 0.5.3-1.
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
CVE-2012-4560- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
CVE-2012-4560- Updated
- 2026-11-02
EUVDEUVD-2012-4488 No score
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
EUVD-2012-4488- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q6mh-jmqc-qqqq No score
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of...
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
GHSA-q6mh-jmqc-qqqq- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
CVE-2012-4560- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-4560 No score
Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
- Record
DEBIAN-CVE-2012-4560- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10036-1 No score
libssh-devel-0.7.2-2.1 on GA media
These are all security issues fixed in the libssh-devel-0.7.2-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10036-1- Updated
- 2026-11-02
Affected products
Affected packages
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
mandriva.com/security/advisories?name=MDVSA-2012:175
bugzilla.redhat.com/show_bug.cgi?id=871614
ubuntu.com/usn/USN-1640-1
lists.opensuse.org/opensuse-updates/2013-01/msg00021.html
lists.opensuse.org/opensuse-updates/2012-12/msg00016.html
lists.fedoraproject.org/pipermail/package-announce/2012-November/093313.html
Show 16 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/80219
lists.opensuse.org/opensuse-security-announce/2012-12/msg00002.html
openwall.com/lists/oss-security/2012/11/20/3
lists.fedoraproject.org/pipermail/package-announce/2012-November/093474.html
securityfocus.com/bid/56604
libssh.org/2012/11/20/libssh-0-5-3-security-release
nvd.nist.gov/vuln/detail/CVE-2012-4560
github.com/advisories/GHSA-q6mh-jmqc-qqqq
security-tracker.debian.org/tracker/CVE-2012-4560
suse.com/security/cve/CVE-2012-4559
suse.com/security/cve/CVE-2012-4560
suse.com/security/cve/CVE-2012-4561
suse.com/security/cve/CVE-2013-0176
suse.com/security/cve/CVE-2014-0017
suse.com/security/cve/CVE-2014-8132
suse.com/security/cve/CVE-2015-3146