Every CVE Search/ Get API key

CVE-2012-4560

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of...

7.5 HighFix available

CVE-2012-4560 is a high vulnerability (CVSS 7.5) in Libssh, published November 30, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.45%, the 93rd percentile. Fixed in libssh 0.5.3-1.

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Exploit likelihood

6.45%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2012-4560
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2012-4560
Updated
2026-11-02
EUVDEUVD-2012-4488 No score

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
EUVD-2012-4488
Updated
2026-11-03
GitHub AdvisoriesGHSA-q6mh-jmqc-qqqq No score

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of...

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
GHSA-q6mh-jmqc-qqqq
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
CVE-2012-4560
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4560 No score

Multiple buffer overflows in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

Record
DEBIAN-CVE-2012-4560
Updated
2026-11-02
OSVopenSUSE-SU-2024:10036-1 No score

libssh-devel-0.7.2-2.1 on GA media

These are all security issues fixed in the libssh-devel-0.7.2-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10036-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libssh
Debian:12
before 0.5.3-1
0.5.3-1
libssh
Debian:13
before 0.5.3-1
0.5.3-1
libssh
Debian:14
before 0.5.3-1
0.5.3-1
libssh
openSUSE:Tumbleweed
before 0.7.2-2.1
0.7.2-2.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 16 moreShow less
MoveEnter Open