CVE-2012-6639
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an...
CVE-2012-6639 is a high vulnerability (CVSS 8.8) in Canonical Cloud-init, published November 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.05%, the 81st percentile. Fixed in cloud-init 0.7.1-1.
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
CVE-2012-6639- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
CVE-2012-6639- Updated
- 2026-11-02
EUVDEUVD-2012-6485 No score
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
EUVD-2012-6485- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-53qp-p4j3-jj3w
8.8
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an...
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
GHSA-53qp-p4j3-jj3w- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSV
8.8
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
CVE-2012-6639- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-6639
8.8
An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.
- Record
DEBIAN-CVE-2012-6639- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cloud-initDebian:12 |
before 0.7.1-1 | 0.7.1-1 |
cloud-initDebian:13 |
before 0.7.1-1 | 0.7.1-1 |
cloud-initDebian:14 |
before 0.7.1-1 | 0.7.1-1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
security-tracker.debian.org/tracker/CVE-2012-6639
bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-6639
bugzilla.suse.com/show_bug.cgi?id=CVE-2012-6639
access.redhat.com/security/cve/cve-2012-6639
openwall.com/lists/oss-security/2014/03/06/7
securityfocus.com/bid/66019/references
nvd.nist.gov/vuln/detail/CVE-2012-6639
github.com/advisories/GHSA-53qp-p4j3-jj3w