Every CVE Search/ Get API key

CVE-2012-6639

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an...

8.8 HighFix available

CVE-2012-6639 is a high vulnerability (CVSS 8.8) in Canonical Cloud-init, published November 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.05%, the 81st percentile. Fixed in cloud-init 0.7.1-1.

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.05%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
CVE-2012-6639
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
CVE-2012-6639
Updated
2026-11-02
EUVDEUVD-2012-6485 No score

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
EUVD-2012-6485
Updated
2026-11-03
GitHub AdvisoriesGHSA-53qp-p4j3-jj3w 8.8

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an...

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
GHSA-53qp-p4j3-jj3w
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-269
Updated
2026-11-02
OSV 8.8

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
CVE-2012-6639
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2012-6639 8.8

An privilege elevation vulnerability exists in Cloud-init before 0.7.0 when requests to an untrusted system are submitted for EC2 instance data.

Record
DEBIAN-CVE-2012-6639
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cloud-init
Debian:12
before 0.7.1-1
0.7.1-1
cloud-init
Debian:13
before 0.7.1-1
0.7.1-1
cloud-init
Debian:14
before 0.7.1-1
0.7.1-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open