Every CVE Search/ Get API key

CVE-2013-2104

python-keystoneclient missing expiration check in PKI token validation

5.5 MediumFix available

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Exploit likelihood

2.08%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
CVE-2013-2104
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:N/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
CVE-2013-2104
Updated
2026-11-02
EUVDEUVD-2014-0091 No score

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
EUVD-2014-0091
Updated
2026-11-03
GitHub AdvisoriesGHSA-4rrr-j7ff-r844 8.7

python-keystoneclient missing expiration check in PKI token validation

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
GHSA-4rrr-j7ff-r844
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-324
Updated
2026-11-02
OSVGHSA-4rrr-j7ff-r844 8.7

python-keystoneclient missing expiration check in PKI token validation

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
GHSA-4rrr-j7ff-r844
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-324
Updated
2026-11-02
OSV No score

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
CVE-2013-2104
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2104 No score

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
DEBIAN-CVE-2013-2104
Updated
2026-11-02
OSVPYSEC-2014-69 No score

python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.

Record
PYSEC-2014-69
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
python-keystoneclient
PyPI
before 0.2.4
0.2.4
python-keystoneclient
Debian:12
before 1:0.2.5-1
1:0.2.5-1
python-keystoneclient
Debian:13
before 1:0.2.5-1
1:0.2.5-1
python-keystoneclient
Debian:14
before 1:0.2.5-1
1:0.2.5-1
python-keystoneclient
PyPI
before 0.2.4, plus listed versions
0.1.10.1.20.1.30.2.00.2.10.2.20.2.3
0.2.4
python-keystoneclient
Red Hat:openstack:3::el6
before 1:0.2.3-2.el6ost
1:0.2.3-2.el6ost
python-keystoneclient-doc
Red Hat:openstack:3::el6
before 1:0.2.3-2.el6ost
1:0.2.3-2.el6ost

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2104 is a medium vulnerability (CVSS 5.5) in Openstack Python-keystoneclient, published January 21, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in python-keystoneclient 0.2.4.

References

Show 13 moreShow less
MoveEnter Open