CVE-2013-2104
python-keystoneclient missing expiration check in PKI token validation
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
Exploit likelihood
What each source reports
NVD Score used
5.5
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
CVE-2013-2104- CVSS 2.0
- 5.5 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
CVE-2013-2104- Updated
- 2026-11-02
EUVDEUVD-2014-0091 No score
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
EUVD-2014-0091- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4rrr-j7ff-r844
8.7
python-keystoneclient missing expiration check in PKI token validation
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
GHSA-4rrr-j7ff-r844- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-324
- Updated
- 2026-11-02
OSVGHSA-4rrr-j7ff-r844
8.7
python-keystoneclient missing expiration check in PKI token validation
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
GHSA-4rrr-j7ff-r844- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-324
- Updated
- 2026-11-02
OSV No score
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
CVE-2013-2104- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-2104 No score
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
DEBIAN-CVE-2013-2104- Updated
- 2026-11-02
OSVPYSEC-2014-69 No score
python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
- Record
PYSEC-2014-69- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-keystoneclientPyPI |
before 0.2.4 | 0.2.4 |
python-keystoneclientDebian:12 |
before 1:0.2.5-1 | 1:0.2.5-1 |
python-keystoneclientDebian:13 |
before 1:0.2.5-1 | 1:0.2.5-1 |
python-keystoneclientDebian:14 |
before 1:0.2.5-1 | 1:0.2.5-1 |
python-keystoneclientPyPI |
before 0.2.4, plus listed versions 0.1.10.1.20.1.30.2.00.2.10.2.20.2.3 |
0.2.4 |
python-keystoneclientRed Hat:openstack:3::el6 |
before 1:0.2.3-2.el6ost | 1:0.2.3-2.el6ost |
python-keystoneclient-docRed Hat:openstack:3::el6 |
before 1:0.2.3-2.el6ost | 1:0.2.3-2.el6ost |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2104 is a medium vulnerability (CVSS 5.5) in Openstack Python-keystoneclient, published January 21, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in python-keystoneclient 0.2.4.
References
openwall.com/lists/oss-security/2013/05/28/7
ubuntu.com/usn/USN-1851-1
rhn.redhat.com/errata/RHSA-2013-0944.html
lists.opensuse.org/opensuse-updates/2013-06/msg00198.html
bugs.launchpad.net/python-keystoneclient/+bug/1179615
ubuntu.com/usn/USN-1875-1
Show 13 moreShow less
nvd.nist.gov/vuln/detail/CVE-2013-2104
access.redhat.com/errata/RHSA-2013:0944
access.redhat.com/security/cve/CVE-2013-2104
bugzilla.redhat.com/show_bug.cgi?id=965852
github.com/pypa/advisory-database/tree/main/vulns/python-keystoneclient/PYSEC-2014-69.yaml
github.com/advisories/GHSA-4rrr-j7ff-r844
security-tracker.debian.org/tracker/CVE-2013-2104
github.com/openstack/python-keystoneclient
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=904351
bugzilla.redhat.com/show_bug.cgi?id=928558
security.access.redhat.com/data/csaf/v2/advisories/2013/rhsa-2013_0944.json
cve.org/CVERecord?id=CVE-2013-2104