CVE-2014-0228
Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
Exploit likelihood
What each source reports
NVD Score used
3.5
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
- Record
CVE-2014-0228- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:P/I:N/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
CVE List No score
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
- Record
CVE-2014-0228- Updated
- 2026-11-02
EUVDEUVD-2018-0782 No score
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
- Record
EUVD-2018-0782- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w4x9-4f5x-8jj8 No score
Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
- Record
GHSA-w4x9-4f5x-8jj8- Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-w4x9-4f5x-8jj8 No score
Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
- Record
GHSA-w4x9-4f5x-8jj8- Weakness
- CWE-284
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.hive:hiveMaven |
before 0.13.1 | 0.13.1 |
org.apache.hive:hive-serviceMaven |
before 0.13.1 | 0.13.1 |
org.apache.hive:hive-execMaven |
before 0.13.1 | 0.13.1 |
org.apache.hive:hiveMaven |
before 0.13.1, plus listed versions 0.13.0 |
0.13.1 |
org.apache.hive:hive-execMaven |
before 0.13.1, plus listed versions 0.10.00.11.00.12.00.13.00.8.00.8.10.9.0 |
0.13.1 |
org.apache.hive:hive-serviceMaven |
before 0.13.1, plus listed versions 0.10.00.11.00.12.00.13.00.8.00.8.10.9.0 |
0.13.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-0228 is a low vulnerability (CVSS 3.5) in Apache Hive, published November 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.50%, the 89th percentile. Fixed in org.apache.hive:hive 0.13.1.
References
mail-archives.apache.org/mod_mbox/hive-user/201406.mbox/%3CCABgNGzeN7E+9d=YV5yvnKA7wmSx1op_avtUjPcPtDaR6DLJM6g%40mail.gmail.com%3E
packetstormsecurity.com/files/127091/Apache-Hive-0.13.0-Authorization-Failure.html
securityfocus.com/archive/1/532418/100/0/threaded
nvd.nist.gov/vuln/detail/CVE-2014-0228
github.com/advisories/GHSA-w4x9-4f5x-8jj8
mail-archives.apache.org/mod_mbox/hive-user/201406.mbox/%3CCABgNGzeN7E+[email protected]%3E