Every CVE Search/ Get API key

CVE-2014-0228

Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service

3.5 LowFix available

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Exploit likelihood

3.50%Up 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Record
CVE-2014-0228
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:P/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Record
CVE-2014-0228
Updated
2026-11-02
EUVDEUVD-2018-0782 No score

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Record
EUVD-2018-0782
Updated
2026-11-03
GitHub AdvisoriesGHSA-w4x9-4f5x-8jj8 No score

Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Record
GHSA-w4x9-4f5x-8jj8
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-w4x9-4f5x-8jj8 No score

Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Record
GHSA-w4x9-4f5x-8jj8
Weakness
CWE-284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hive:hive
Maven
before 0.13.1
0.13.1
org.apache.hive:hive-service
Maven
before 0.13.1
0.13.1
org.apache.hive:hive-exec
Maven
before 0.13.1
0.13.1
org.apache.hive:hive
Maven
before 0.13.1, plus listed versions
0.13.0
0.13.1
org.apache.hive:hive-exec
Maven
before 0.13.1, plus listed versions
0.10.00.11.00.12.00.13.00.8.00.8.10.9.0
0.13.1
org.apache.hive:hive-service
Maven
before 0.13.1, plus listed versions
0.10.00.11.00.12.00.13.00.8.00.8.10.9.0
0.13.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0228 is a low vulnerability (CVSS 3.5) in Apache Hive, published November 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.50%, the 89th percentile. Fixed in org.apache.hive:hive 0.13.1.

References

MoveEnter Open