Every CVE Search/ Get API key

CVE-2014-0466

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows...

6.8 MediumFix available

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Exploit likelihood

2.35%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
CVE-2014-0466
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
CVE-2014-0466
Updated
2026-11-02
EUVDEUVD-2014-0504 No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
EUVD-2014-0504
Updated
2026-11-03
GitHub AdvisoriesGHSA-5wf6-vx35-ff8x No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows...

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
GHSA-5wf6-vx35-ff8x
Updated
2026-11-02
OSV No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
CVE-2014-0466
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0466 No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
DEBIAN-CVE-2014-0466
Updated
2026-11-02
OSVMGASA-2014-0161 No score

Updated a2ps packages fix CVE-2014-0466

Updated a2ps packages fix security vulnerability:

Brian M. Carlson reported that a2ps's fixps script does not invoke gs with the -dSAFER option. Consequently executing fixps on a malicious PostScript file could result in files being deleted or arbitrary commands being executed with the privileges of the user running fixps (CVE-2014-0466).

Record
MGASA-2014-0161
Updated
2026-11-02
OSVopenSUSE-SU-2024:10086-1 No score

a2ps-4.14-6.6 on GA media

These are all security issues fixed in the a2ps-4.14-6.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10086-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0466 No score

The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.

Record
UBUNTU-CVE-2014-0466
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
a2ps
Debian:12
before 1:4.14-1.3
1:4.14-1.3
a2ps
Debian:13
before 1:4.14-1.3
1:4.14-1.3
a2ps
Debian:14
before 1:4.14-1.3
1:4.14-1.3
a2ps
Debian:6.0
before 1:4.14-1.1+deb6u1, plus listed versions
1:4.14-1.1
1:4.14-1.1+deb6u1
a2ps
Debian:7
before 1:4.14-1.1+deb7u1, plus listed versions
1:4.14-1.1
1:4.14-1.1+deb7u1
a2ps
Mageia:3
before 4.14-12.2.mga3
4.14-12.2.mga3
a2ps
Mageia:4
before 4.14-13.1.mga4
4.14-13.1.mga4
a2ps
openSUSE:Tumbleweed
before 4.14-6.6
4.14-6.6

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0466 is a medium vulnerability (CVSS 6.8) in Gnu A2ps, published March 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in a2ps 1:4.14-1.3.

References

Show 8 moreShow less
MoveEnter Open