CVE-2014-0466
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows...
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
Exploit likelihood
What each source reports
NVD Score used
6.8
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
CVE-2014-0466- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
CVE-2014-0466- Updated
- 2026-11-02
EUVDEUVD-2014-0504 No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
EUVD-2014-0504- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5wf6-vx35-ff8x No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows...
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
GHSA-5wf6-vx35-ff8x- Updated
- 2026-11-02
OSV No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
CVE-2014-0466- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-0466 No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
DEBIAN-CVE-2014-0466- Updated
- 2026-11-02
OSVMGASA-2014-0161 No score
Updated a2ps packages fix CVE-2014-0466
Updated a2ps packages fix security vulnerability:
Brian M. Carlson reported that a2ps's fixps script does not invoke gs with the -dSAFER option. Consequently executing fixps on a malicious PostScript file could result in files being deleted or arbitrary commands being executed with the privileges of the user running fixps (CVE-2014-0466).
- Record
MGASA-2014-0161- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10086-1 No score
a2ps-4.14-6.6 on GA media
These are all security issues fixed in the a2ps-4.14-6.6 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10086-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-0466 No score
The fixps script in a2ps 4.14 does not use the -dSAFER option when executing gs, which allows context-dependent attackers to delete arbitrary files or execute arbitrary commands via a crafted PostScript file.
- Record
UBUNTU-CVE-2014-0466- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
a2psDebian:12 |
before 1:4.14-1.3 | 1:4.14-1.3 |
a2psDebian:13 |
before 1:4.14-1.3 | 1:4.14-1.3 |
a2psDebian:14 |
before 1:4.14-1.3 | 1:4.14-1.3 |
a2psDebian:6.0 |
before 1:4.14-1.1+deb6u1, plus listed versions 1:4.14-1.1 |
1:4.14-1.1+deb6u1 |
a2psDebian:7 |
before 1:4.14-1.1+deb7u1, plus listed versions 1:4.14-1.1 |
1:4.14-1.1+deb7u1 |
a2psMageia:3 |
before 4.14-12.2.mga3 | 4.14-12.2.mga3 |
a2psMageia:4 |
before 4.14-13.1.mga4 | 4.14-13.1.mga4 |
a2psopenSUSE:Tumbleweed |
before 4.14-6.6 | 4.14-6.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-0466 is a medium vulnerability (CVSS 6.8) in Gnu A2ps, published March 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in a2ps 1:4.14-1.3.
References
bugs.debian.org/cgi-bin/bugreport.cgi?bug=742902
securityfocus.com/bid/66660
security.gentoo.org/glsa/201701-67
lists.opensuse.org/opensuse-updates/2014-04/msg00021.html
debian.org/security/2014/dsa-2892
nvd.nist.gov/vuln/detail/CVE-2014-0466
Show 8 moreShow less
github.com/advisories/GHSA-5wf6-vx35-ff8x
security-tracker.debian.org/tracker/CVE-2014-0466
advisories.mageia.org/MGASA-2014-0161.html
bugs.mageia.org/show_bug.cgi?id=13130
ubuntu.com/security/CVE-2014-0466
cve.org/CVERecord?id=CVE-2014-0466
suse.com/security/cve/CVE-2004-1377
suse.com/security/cve/CVE-2014-0466