Every CVE Search/ Get API key

CVE-2014-1928

python-gnupg's shell_quote function does not properly escape characters

4.6 MediumFix available

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Exploit likelihood

0.61%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
CVE-2014-1928
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
CVE-2014-1928
Updated
2026-11-02
EUVDEUVD-2014-0089 No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
EUVD-2014-0089
Updated
2026-11-03
GitHub AdvisoriesGHSA-2jc8-4r6g-282j 8.7

python-gnupg's shell_quote function does not properly escape characters

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
GHSA-2jc8-4r6g-282j
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-2jc8-4r6g-282j 8.7

python-gnupg's shell_quote function does not properly escape characters

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
GHSA-2jc8-4r6g-282j
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
CVE-2014-1928
Updated
2026-11-02
OSVDEBIAN-CVE-2014-1928 No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
DEBIAN-CVE-2014-1928
Updated
2026-11-02
OSVPYSEC-2014-91 No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
PYSEC-2014-91
Updated
2026-11-02
OSVUBUNTU-CVE-2014-1928 No score

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Record
UBUNTU-CVE-2014-1928
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
python-gnupg
PyPI
0.3.5 to 0.3.5
0.3.6
python-gnupg
Debian:12
before 0.3.6-1
0.3.6-1
python-gnupg
Debian:13
before 0.3.6-1
0.3.6-1
python-gnupg
Debian:14
before 0.3.6-1
0.3.6-1
python-gnupg
Debian:7
From an advisory covering 4 CVEs
before 0.3.6-1~deb7u1, plus listed versions
0.3.0-1.10.3.4-10.3.5-10.3.5-2
0.3.6-1~deb7u1
python-gnupg
PyPI
0.3.5 up to 0.3.6
0.3.6
python-gnupg
PyPI
before 0.3.6, plus listed versions
0.2.30.2.40.2.60.2.70.2.8
Show 7 moreShow less
0.2.90.3.00.3.10.3.20.3.30.3.40.3.5
0.3.6

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-1928 is a medium vulnerability (CVSS 4.6) in Python-gnupg Project Python-gnupg, published June 4, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in python-gnupg 0.3.6.

References

Show 8 moreShow less
MoveEnter Open