CVE-2014-1928
python-gnupg's shell_quote function does not properly escape characters
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Exploit likelihood
What each source reports
NVD Score used
4.6
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1928- CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1928- Updated
- 2026-11-02
EUVDEUVD-2014-0089 No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
EUVD-2014-0089- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2jc8-4r6g-282j
8.7
python-gnupg's shell_quote function does not properly escape characters
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
GHSA-2jc8-4r6g-282j- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-2jc8-4r6g-282j
8.7
python-gnupg's shell_quote function does not properly escape characters
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
GHSA-2jc8-4r6g-282j- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1928- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-1928 No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
DEBIAN-CVE-2014-1928- Updated
- 2026-11-02
OSVPYSEC-2014-91 No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
PYSEC-2014-91- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-1928 No score
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
UBUNTU-CVE-2014-1928- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-gnupgPyPI |
0.3.5 to 0.3.5 | 0.3.6 |
python-gnupgDebian:12 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:13 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:14 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:7 From an advisory covering 4 CVEs |
before 0.3.6-1~deb7u1, plus listed versions 0.3.0-1.10.3.4-10.3.5-10.3.5-2 |
0.3.6-1~deb7u1 |
python-gnupgPyPI |
0.3.5 up to 0.3.6 | 0.3.6 |
python-gnupgPyPI |
before 0.3.6, plus listed versions 0.2.30.2.40.2.60.2.70.2.8 Show 7 moreShow less0.2.90.3.00.3.10.3.20.3.30.3.40.3.5 |
0.3.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-1928 is a medium vulnerability (CVSS 4.6) in Python-gnupg Project Python-gnupg, published June 4, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in python-gnupg 0.3.6.
References
secunia.com/advisories/56616
seclists.org/oss-sec/2014/q1/246
debian.org/security/2014/dsa-2946
code.google.com/p/python-gnupg/issues/detail?id=98
code.google.com/p/python-gnupg
seclists.org/oss-sec/2014/q1/294
Show 8 moreShow less
secunia.com/advisories/59031
nvd.nist.gov/vuln/detail/CVE-2014-1928
github.com/advisories/GHSA-2jc8-4r6g-282j
github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-91.yaml
security-tracker.debian.org/tracker/CVE-2014-1928
ubuntu.com/security/CVE-2014-1928
openwall.com/lists/oss-security/2014/02/09/1
cve.org/CVERecord?id=CVE-2014-1928