Every CVE Search/ Get API key

CVE-2014-1959

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509...

5.8 MediumFix available

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Exploit likelihood

3.40%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
CVE-2014-1959
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
CVE-2014-1959
Updated
2026-11-02
EUVDEUVD-2014-2012 No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
EUVD-2014-2012
Updated
2026-11-03
GitHub AdvisoriesGHSA-pcqq-cwj9-7ggm No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509...

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
GHSA-pcqq-cwj9-7ggm
Updated
2026-11-02
OSV No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
CVE-2014-1959
Updated
2026-11-02
OSVDEBIAN-CVE-2014-1959 No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
DEBIAN-CVE-2014-1959
Updated
2026-11-02
OSVMGASA-2014-0077 No score

Updated gnutls packages fix security vulnerability

Suman Jana reported a vulnerability that affects the certificate verification functions of gnutls 3.1.x and gnutls 3.2.x. A version 1 intermediate certificate will be considered as a CA certificate by default (something that deviates from the documented behavior) (CVE-2014-1959).

Record
MGASA-2014-0077
Updated
2026-11-02
OSVopenSUSE-SU-2024:10105-1 No score

gnutls-3.4.15-1.1 on GA media

These are all security issues fixed in the gnutls-3.4.15-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10105-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-1959 No score

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

Record
UBUNTU-CVE-2014-1959
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnutls28
Debian:12
before 3.2.11-1
3.2.11-1
gnutls28
Debian:13
before 3.2.11-1
3.2.11-1
gnutls28
Debian:14
before 3.2.11-1
3.2.11-1
gnutls26
Debian:7
before 2.12.20-8, plus listed versions
2.12.20-62.12.20-7
2.12.20-8
gnutls
Mageia:3
before 3.1.16-1.1.mga3
3.1.16-1.1.mga3
gnutls
Mageia:4
before 3.2.7-1.1.mga4
3.2.7-1.1.mga4
gnutls26
Ubuntu:14.04:LTS
before 2.12.23-12ubuntu1, plus listed versions
2.12.23-1ubuntu42.12.23-1ubuntu5
2.12.23-12ubuntu1
gnutls
openSUSE:Tumbleweed
From an advisory covering 10 CVEs
before 3.4.15-1.1
3.4.15-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-1959 is a medium vulnerability (CVSS 5.8) in Gnu Gnutls, published February 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.40%, the 88th percentile. Fixed in gnutls28 3.2.11-1.

References

Show 20 moreShow less
MoveEnter Open