CVE-2014-1959
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509...
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
Exploit likelihood
What each source reports
NVD Score used
5.8
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
CVE-2014-1959- CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
CVE-2014-1959- Updated
- 2026-11-02
EUVDEUVD-2014-2012 No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
EUVD-2014-2012- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pcqq-cwj9-7ggm No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509...
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
GHSA-pcqq-cwj9-7ggm- Updated
- 2026-11-02
OSV No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
CVE-2014-1959- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-1959 No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
DEBIAN-CVE-2014-1959- Updated
- 2026-11-02
OSVMGASA-2014-0077 No score
Updated gnutls packages fix security vulnerability
Suman Jana reported a vulnerability that affects the certificate verification functions of gnutls 3.1.x and gnutls 3.2.x. A version 1 intermediate certificate will be considered as a CA certificate by default (something that deviates from the documented behavior) (CVE-2014-1959).
- Record
MGASA-2014-0077- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10105-1 No score
gnutls-3.4.15-1.1 on GA media
These are all security issues fixed in the gnutls-3.4.15-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10105-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-1959 No score
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
- Record
UBUNTU-CVE-2014-1959- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gnutls28Debian:12 |
before 3.2.11-1 | 3.2.11-1 |
gnutls28Debian:13 |
before 3.2.11-1 | 3.2.11-1 |
gnutls28Debian:14 |
before 3.2.11-1 | 3.2.11-1 |
gnutls26Debian:7 |
before 2.12.20-8, plus listed versions 2.12.20-62.12.20-7 |
2.12.20-8 |
gnutlsMageia:3 |
before 3.1.16-1.1.mga3 | 3.1.16-1.1.mga3 |
gnutlsMageia:4 |
before 3.2.7-1.1.mga4 | 3.2.7-1.1.mga4 |
gnutls26Ubuntu:14.04:LTS |
before 2.12.23-12ubuntu1, plus listed versions 2.12.23-1ubuntu42.12.23-1ubuntu5 |
2.12.23-12ubuntu1 |
gnutlsopenSUSE:Tumbleweed From an advisory covering 10 CVEs |
before 3.4.15-1.1 | 3.4.15-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-1959 is a medium vulnerability (CVSS 5.8) in Gnu Gnutls, published February 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.40%, the 88th percentile. Fixed in gnutls28 3.2.11-1.
References
gnutls.org/security.html
seclists.org/oss-sec/2014/q1/344
seclists.org/oss-sec/2014/q1/345
securityfocus.com/bid/65559
ubuntu.com/usn/USN-2121-1
gitorious.org/gnutls/gnutls/commit/b1abfe3d182d68539900092eb42fc62cf1bb7e7c
Show 20 moreShow less
debian.org/security/2014/dsa-2866
nvd.nist.gov/vuln/detail/CVE-2014-1959
github.com/advisories/GHSA-pcqq-cwj9-7ggm
security-tracker.debian.org/tracker/CVE-2014-1959
advisories.mageia.org/MGASA-2014-0077.html
bugs.mageia.org/show_bug.cgi?id=12763
ubuntu.com/security/CVE-2014-1959
gitorious.org/gnutls/gnutls/commit/b1abfe3d18
ubuntu.com/security/notices/USN-2121-1
cve.org/CVERecord?id=CVE-2014-1959
suse.com/security/cve/CVE-2008-4989
suse.com/security/cve/CVE-2011-4128
suse.com/security/cve/CVE-2012-0390
suse.com/security/cve/CVE-2012-1569
suse.com/security/cve/CVE-2012-1573
suse.com/security/cve/CVE-2014-0092
suse.com/security/cve/CVE-2014-1959
suse.com/security/cve/CVE-2014-3466
suse.com/security/cve/CVE-2014-8564
suse.com/security/cve/CVE-2015-6251