Every CVE Search/ Get API key

CVE-2014-3158

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before...

7.5 HighFix available

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Exploit likelihood

3.55%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
CVE-2014-3158
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
CVE-2014-3158
Updated
2026-11-02
EUVDEUVD-2014-3176 No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
EUVD-2014-3176
Updated
2026-11-03
GitHub AdvisoriesGHSA-4rmp-xhjh-jrfr No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before...

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
GHSA-4rmp-xhjh-jrfr
Weakness
CWE-119
Updated
2026-11-02
OSVBELL-CVE-2014-3158 7.5

CVE-2014-3158 does not affect BellSoft software

Record
BELL-CVE-2014-3158
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
OSV No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
CVE-2014-3158
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2014-3158 No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
DEBIAN-CVE-2014-3158
Updated
2026-11-02
OSVMGASA-2014-0368 No score

Updated ppp packages fix a security vulnerability

Updated ppp packages fix security vulnerability:

A vulnerability in ppp before 2.4.7 may enable an unprivileged attacker to access privileged options (CVE-2014-3158).

Record
MGASA-2014-0368
Updated
2026-11-02
OSVopenSUSE-SU-2024:10049-1 No score

ppp-2.4.7-7.1 on GA media

These are all security issues fixed in the ppp-2.4.7-7.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10049-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3158 No score

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Record
UBUNTU-CVE-2014-3158
Updated
2026-11-02
OSVUSN-2429-1 No score

ppp vulnerability

It was discovered that ppp incorrectly handled certain options files. A local attacker could possibly use this issue to escalate privileges.

Record
USN-2429-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ppp
Debian:12
before 2.4.6-3
2.4.6-3
ppp
Debian:13
before 2.4.6-3
2.4.6-3
ppp
Debian:14
before 2.4.6-3
2.4.6-3
ppp
Debian:6.0
before 2.4.5-4+deb6u1, plus listed versions
2.4.5-4
2.4.5-4+deb6u1
ppp
Debian:7
before 2.4.5-5.1+deb7u1, plus listed versions
2.4.5-5.1
2.4.5-5.1+deb7u1
ppp
Mageia:3
before 2.4.5-15.3.mga3
2.4.5-15.3.mga3
ppp
Mageia:4
before 2.4.5-17.1.mga4
2.4.5-17.1.mga4
ppp
Ubuntu:14.04:LTS
before 2.4.5-5.1ubuntu2.1, plus listed versions
2.4.5-5.1ubuntu2
2.4.5-5.1ubuntu2.1
ppp
openSUSE:Tumbleweed
before 2.4.7-7.1
2.4.7-7.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3158 is a high vulnerability (CVSS 7.5) in Point-to-point Protocol Project Protocol, published September 5, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.55%, the 89th percentile. Fixed in ppp 2.4.6-3.

References

Show 13 moreShow less
MoveEnter Open