CVE-2014-3158
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before...
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
Exploit likelihood
What each source reports
NVD Score used
7.5
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
CVE-2014-3158- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
CVE-2014-3158- Updated
- 2026-11-02
EUVDEUVD-2014-3176 No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
EUVD-2014-3176- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4rmp-xhjh-jrfr No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before...
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
GHSA-4rmp-xhjh-jrfr- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVBELL-CVE-2014-3158
7.5
CVE-2014-3158 does not affect BellSoft software
- Record
BELL-CVE-2014-3158- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
OSV No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
CVE-2014-3158- Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2014-3158 No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
DEBIAN-CVE-2014-3158- Updated
- 2026-11-02
OSVMGASA-2014-0368 No score
Updated ppp packages fix a security vulnerability
Updated ppp packages fix security vulnerability:
A vulnerability in ppp before 2.4.7 may enable an unprivileged attacker to access privileged options (CVE-2014-3158).
- Record
MGASA-2014-0368- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10049-1 No score
ppp-2.4.7-7.1 on GA media
These are all security issues fixed in the ppp-2.4.7-7.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10049-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-3158 No score
Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."
- Record
UBUNTU-CVE-2014-3158- Updated
- 2026-11-02
OSVUSN-2429-1 No score
ppp vulnerability
It was discovered that ppp incorrectly handled certain options files. A local attacker could possibly use this issue to escalate privileges.
- Record
USN-2429-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pppDebian:12 |
before 2.4.6-3 | 2.4.6-3 |
pppDebian:13 |
before 2.4.6-3 | 2.4.6-3 |
pppDebian:14 |
before 2.4.6-3 | 2.4.6-3 |
pppDebian:6.0 |
before 2.4.5-4+deb6u1, plus listed versions 2.4.5-4 |
2.4.5-4+deb6u1 |
pppDebian:7 |
before 2.4.5-5.1+deb7u1, plus listed versions 2.4.5-5.1 |
2.4.5-5.1+deb7u1 |
pppMageia:3 |
before 2.4.5-15.3.mga3 | 2.4.5-15.3.mga3 |
pppMageia:4 |
before 2.4.5-17.1.mga4 | 2.4.5-17.1.mga4 |
pppUbuntu:14.04:LTS |
before 2.4.5-5.1ubuntu2.1, plus listed versions 2.4.5-5.1ubuntu2 |
2.4.5-5.1ubuntu2.1 |
pppopenSUSE:Tumbleweed |
before 2.4.7-7.1 | 2.4.7-7.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3158 is a high vulnerability (CVSS 7.5) in Point-to-point Protocol Project Protocol, published September 5, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.55%, the 89th percentile. Fixed in ppp 2.4.6-3.
References
ubuntu.com/usn/USN-2429-1
marc.info?l=linux-ppp&m=140764978420764
mandriva.com/security/advisories?name=MDVSA-2015:135
oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
bugzilla.redhat.com/show_bug.cgi?id=1128748
lists.fedoraproject.org/pipermail/package-announce/2014-August/136932.html
Show 13 moreShow less
debian.org/security/2014/dsa-3079
advisories.mageia.org/MGASA-2014-0368.html
github.com/paulusmack/ppp/commit/7658e8257183f062dc01f87969c140707c7e52cb
nvd.nist.gov/vuln/detail/CVE-2014-3158
github.com/advisories/GHSA-4rmp-xhjh-jrfr
docs.bell-sw.com/security/cves/CVE-2014-3158
security-tracker.debian.org/tracker/CVE-2014-3158
bugs.mageia.org/show_bug.cgi?id=13996
ubuntu.com/security/CVE-2014-3158
ubuntu.com/security/notices/USN-2429-1
cve.org/CVERecord?id=CVE-2014-3158
suse.com/security/cve/CVE-2014-3158
suse.com/security/cve/CVE-2015-3310