Every CVE Search/ Get API key

CVE-2014-5002

lynx doesn't properly sanitize user input and exposes database password to unauthorized users

7.8 HighFix available

The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.52%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

Record
CVE-2014-5002
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-255
Updated
2026-11-02
CVE List No score

The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

Record
CVE-2014-5002
Updated
2026-11-02
EUVDEUVD-2018-0157 No score

The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

Record
EUVD-2018-0157
Updated
2026-11-03
GitHub AdvisoriesGHSA-94cq-7ccq-cmcm 7.8

lynx doesn't properly sanitize user input and exposes database password to unauthorized users

The lynx gem prior to 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

As of version 1.0.0, lynx no longer supports a --password option. Passwords are only configured in a configuration file, so it's no longer possible to expose passwords on the command line.

Record
GHSA-94cq-7ccq-cmcm
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-200
Updated
2026-11-02
OSVGHSA-94cq-7ccq-cmcm 7.8

lynx doesn't properly sanitize user input and exposes database password to unauthorized users

The lynx gem prior to 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.

As of version 1.0.0, lynx no longer supports a --password option. Passwords are only configured in a configuration file, so it's no longer possible to expose passwords on the command line.

Record
GHSA-94cq-7ccq-cmcm
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lynx
RubyGems
through 0.4.0
1.0.0
lynx
RubyGems
before 1.0.0, plus listed versions
0.0.10.0.20.1.00.2.00.2.10.3.00.4.0
1.0.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5002 is a high vulnerability (CVSS 7.8) in Lynx Project Lynx, published January 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in lynx 1.0.0.

References

MoveEnter Open