Every CVE Search/ Get API key

CVE-2014-9462

Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command

7.5 HighFix available

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Exploit likelihood

4.17%Up 2.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
CVE-2014-9462
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
CVE-2014-9462
Updated
2026-11-02
EUVDEUVD-2015-0029 No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
EUVD-2015-0029
Updated
2026-11-03
GitHub AdvisoriesGHSA-3pmw-h7j4-rf54 9.3

Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
GHSA-3pmw-h7j4-rf54
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-3pmw-h7j4-rf54 9.3

Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
GHSA-3pmw-h7j4-rf54
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
CVE-2014-9462
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2014-9462 No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
DEBIAN-CVE-2014-9462
Updated
2026-11-02
OSVMGASA-2015-0129 No score

Updated mercurial packages fix CVE-2014-9462

Updated mercurial packages fix security vulnerability:

The mercurial source code management system suffers from a code-injection flaw due to insufficient shell quoting in sshpeer._validaterepo() (CVE-2014-9462).

Record
MGASA-2015-0129
Updated
2026-11-02
OSVPYSEC-2015-14 No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
PYSEC-2015-14
Updated
2026-11-02
OSVSUSE-SU-2015:0817-1 No score

Security update for mercurial

mercurial was updated to fix a potential command injection via sshpeer._validaterepo() (CVE-2014-9462)

Security Issues:

* CVE-2014-9462
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9462>
Record
SUSE-SU-2015:0817-1
Updated
2026-11-02
OSVSUSE-SU-2015:0836-1 No score

Security update for mercurial

Mercurial was updated to fix a command injection via sshpeer._validaterepo() (CVE-2014-9462, bnc#923070):

Record
SUSE-SU-2015:0836-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9462 No score

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Record
UBUNTU-CVE-2014-9462
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mercurial
PyPI
before 3.2.4
3.2.4
mercurial
Debian:12
before 3.4-1
3.4-1
mercurial
Debian:13
before 3.4-1
3.4-1
mercurial
Debian:14
before 3.4-1
3.4-1
mercurial
Debian:6.0
before 1.6.4-1+deb6u1, plus listed versions
1.6.4-1
1.6.4-1+deb6u1
mercurial
Debian:7
before 2.2.2-4+deb7u1, plus listed versions
2.2.2-32.2.2-4
2.2.2-4+deb7u1
mercurial
Debian:8
before 3.1.2-2+deb8u1, plus listed versions
3.1.2-2
3.1.2-2+deb8u1
mercurial
PyPI
before 3.2.4, plus listed versions
0.8.10.90.9.10.9.20.9.3
Show 45 moreShow less
0.9.40.9.51.01.0.11.0.21.11.1.11.1.21.21.2.11.31.3.11.41.4.11.4.21.4.31.51.5.11.5.21.5.31.5.41.61.6.11.6.21.6.31.6.41.71.7.11.7.21.7.31.7.51.81.8.11.8.21.8.31.8.41.91.9.11.9.21.9.32.02.0.12.0.22.12.1.1
3.2.4
mercurial
Mageia:4
before 2.7.2-3.1.mga4
2.7.2-3.1.mga4
mercurial
SUSE:Linux Enterprise Software Development Kit 12
before 2.8.2-3.1
2.8.2-3.1
mercurial
Ubuntu:14.04:LTS
before 2.8.2-1ubuntu1.3, plus listed versions
2.6.3-12.7.2-12.8.1-22.8.2-1ubuntu1
2.8.2-1ubuntu1.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9462 is a high vulnerability (CVSS 7.5) in Mercurial, published March 20, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.17%, the 90th percentile. Fixed in mercurial 3.2.4.

References

Show 14 moreShow less
This page doesn't list everything

Left out here: 29 versions. The JSON record has them.

MoveEnter Open