Every CVE Search/ Get API key

CVE-2015-0852

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote...

5.0 MediumFix available

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Exploit likelihood

3.03%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
CVE-2015-0852
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
CVE-2015-0852
Updated
2026-11-02
EUVDEUVD-2015-0863 No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
EUVD-2015-0863
Updated
2026-11-03
GitHub AdvisoriesGHSA-vg9f-qf95-c67j No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote...

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
GHSA-vg9f-qf95-c67j
Updated
2026-11-02
OSV No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
CVE-2015-0852
Updated
2026-11-02
OSVDEBIAN-CVE-2015-0852 No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
DEBIAN-CVE-2015-0852
Updated
2026-11-02
OSVMGASA-2015-0339 No score

Updated freeimage packages fix security vulnerabilities

Updated freeimage packages fix security vulnerability:

FreeImage is vulnerable to an integer overflow in PluginPCX.cpp, making the PCX loader vulnerable to malicious images with a bad window specification (CVE-2015-0852).

Moreover, FreeImage was built in Mageia against a number of bundled libraries with potential security vulnerabilities. Most of those dependencies were unbundled to use the up-to-date system libraries, while the bundled libtiff was updated to a more recent version.

Record
MGASA-2015-0339
Updated
2026-11-02
OSVopenSUSE-SU-2024:10485-1 No score

freeimage-devel-3.17.0-3.3 on GA media

These are all security issues fixed in the freeimage-devel-3.17.0-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10485-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-0852 No score

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

Record
UBUNTU-CVE-2015-0852
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
freeimage
Debian:12
before 3.15.4-5
3.15.4-5
freeimage
Debian:13
before 3.15.4-5
3.15.4-5
freeimage
Debian:6.0
before 3.10.0-4+deb6u1, plus listed versions
3.10.0-4
3.10.0-4+deb6u1
freeimage
Debian:7
before 3.15.1-1.1, plus listed versions
3.15.1-1
3.15.1-1.1
freeimage
Debian:8
before 3.15.4-4.2, plus listed versions
3.15.4-4.1
3.15.4-4.2
freeimage
Mageia:4
before 3.154-1.1.mga4
3.154-1.1.mga4
freeimage
Mageia:5
before 3.154-1.1.mga5
3.154-1.1.mga5
freeimage
Ubuntu:Pro:14.04:LTS
before 3.15.4-3ubuntu0.1+esm1, plus listed versions
3.15.1-2build13.15.1-2build23.15.4-23.15.4-33.15.4-3ubuntu0.1
3.15.4-3ubuntu0.1+esm1
freeimage
openSUSE:Tumbleweed
before 3.17.0-3.3
3.17.0-3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-0852 is a medium vulnerability (CVSS 5.0) in Freeimage Project Freeimage, published September 8, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.03%, the 87th percentile. Fixed in freeimage 3.15.4-5.

References

Show 16 moreShow less
MoveEnter Open